summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-12-01 22:22:30 +0300
committerViktor Drobot2021-12-01 22:22:30 +0300
commit1f8c7d16576881eb5f13f2d1198f6bc0afd145e8 (patch)
treed17522f701926bc999a2feecb683b959a16e495e
parente988161ea324e1a1e1e9cdb0ec989cfe7219a020 (diff)
downloadaur-1f8c7d16576881eb5f13f2d1198f6bc0afd145e8.tar.gz
Update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be9466581f72..9178d80478ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = r-s4vectors
pkgdesc = Foundation of vector-like and list-like containers in Bioconductor
- pkgver = 0.32.2
+ pkgver = 0.32.3
pkgrel = 1
- url = https://bioconductor.org/packages/release/bioc/html/S4Vectors.html
+ url = https://bioconductor.org/packages/S4Vectors
arch = i686
arch = x86_64
license = Artistic-2.0
@@ -16,8 +16,7 @@ pkgbase = r-s4vectors
optdepends = r-data.table
optdepends = r-runit
optdepends = r-biocstyle
- noextract = r-s4vectors-0.32.2.tar.gz
- source = r-s4vectors-0.32.2.tar.gz::https://bioconductor.org/packages/release/bioc/src/contrib/S4Vectors_0.32.2.tar.gz
- sha256sums = 404cef938b087ce70ace47e495004e73ddffe8a492f3d8e4b5d373db448c3577
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/S4Vectors_0.32.3.tar.gz
+ sha256sums = 9c59328e6a5da87171fb52311f680ac2606d8771807381e1348e2517c84ee272
pkgname = r-s4vectors
diff --git a/PKGBUILD b/PKGBUILD
index 1fe6f3b47d7b..bfee8770fc92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,25 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_bcname=S4Vectors
-_bcver=0.32.2
+_bcver=0.32.3
pkgname=r-${_bcname,,}
pkgver=${_bcver//[:-]/.}
pkgrel=1
pkgdesc="Foundation of vector-like and list-like containers in Bioconductor"
arch=(i686 x86_64)
-url="https://bioconductor.org/packages/release/bioc/html/${_bcname}.html"
+url="https://bioconductor.org/packages/${_bcname}"
license=(Artistic-2.0)
depends=('r>=4.0.0' 'r-biocgenerics>=0.37.0')
optdepends=(r-iranges r-genomicranges r-summarizedexperiment r-delayedarray r-shortread r-data.table r-runit r-biocstyle)
-source=("${pkgname}-${pkgver}.tar.gz::https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-noextract=(${pkgname}-${pkgver}.tar.gz)
-sha256sums=('404cef938b087ce70ace47e495004e73ddffe8a492f3d8e4b5d373db448c3577')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
+sha256sums=('9c59328e6a5da87171fb52311f680ac2606d8771807381e1348e2517c84ee272')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${pkgname}-${pkgver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_bcname}" "${pkgdir}/usr/lib/R/library"
}