summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-06-28 08:52:52 -0600
committerMark Wagie2023-06-28 08:52:52 -0600
commit1fb29e8144a852e246ec45bdf424b9eef490b113 (patch)
tree7e81b134185891593da82ebdf5b6b6133642ae02
parent118e3d0cf4d50e9db5b8d614b7c53cd9f6d9d2b4 (diff)
downloadaur-1fb29e8144a852e246ec45bdf424b9eef490b113.tar.gz
2023.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1c1bff91f00..d3d4ef63f57a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn
pkgdesc = The Mullvad VPN client app for desktop
- pkgver = 2023.3
- pkgrel = 2
+ pkgver = 2023.4
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -13,12 +13,12 @@ pkgbase = mullvad-vpn
makedepends = nodejs>=16
makedepends = npm>=8.3
makedepends = protobuf
+ depends = gtk3
depends = iputils
depends = libnotify
- depends = libappindicator-gtk3
depends = nss
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=52bb628c9ef30e68789e02902cc91a40ea8824b5?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=a64b10fdd4c9fefa6d25fd2a94c0ea6cbc7eebc0?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=29a4c7205e78c651fcd1b8c3a55181c0d86a50d3?signed
source = no-rpm.diff
source = mullvad-vpn.sh
diff --git a/PKGBUILD b/PKGBUILD
index e4cbc76e11c9..3fecf8702d14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,17 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
-pkgver=2023.3
-pkgrel=2
+pkgver=2023.4
+pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
arch=('x86_64')
url="https://www.mullvad.net"
license=('GPL3')
-depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
+depends=('gtk3' 'iputils' 'libnotify' 'nss')
makedepends=('cargo' 'git' 'go' 'libxcrypt-compat' 'nodejs>=16' 'npm>=8.3' 'protobuf')
options=('!lto')
install="$pkgname.install"
-_tag=52bb628c9ef30e68789e02902cc91a40ea8824b5 # tags/2023.3^0
+_tag=a64b10fdd4c9fefa6d25fd2a94c0ea6cbc7eebc0 # tags/2023.4^0
_commit=29a4c7205e78c651fcd1b8c3a55181c0d86a50d3
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed"
@@ -87,7 +87,6 @@ build() {
go clean -modcache
echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
- export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release