summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAki Van Ness2021-09-16 20:29:28 -0400
committerAki Van Ness2021-09-16 20:29:28 -0400
commit1fd5054731a9310bacede507c4488b59f961264c (patch)
treede7957b4aa2ed3b05b4ce2d3a0744604816737bf
downloadaur-1fd5054731a9310bacede507c4488b59f961264c.tar.gz
Bumped nextpnr-generic Version to 67bd349e_20212917
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD59
-rw-r--r--PKGBUILD.in59
4 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f914422b5ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = nextpnr-generic-nightly
+ pkgdesc = nextpnr portable FPGA place and route tool - generic
+ pkgver = 67bd349e_20212917
+ pkgrel = 1
+ url = https://github.com/YosysHQ/nextpnr
+ arch = any
+ license = custom:ISC
+ makedepends = git
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = pkgconf
+ makedepends = gawk
+ makedepends = eigen
+ depends = yosys-nightly
+ depends = python
+ depends = boost-libs
+ depends = qt5-base
+ conflicts = nextpnr-git
+ options = !strip
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=67bd349e
+ sha256sums = SKIP
+
+pkgname = nextpnr-generic-nightly
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff301b174ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!PKGBUILD.in
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22ca3169181c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=nextpnr-generic-nightly
+pkgver=67bd349e_20212917
+pkgrel=1
+pkgdesc="nextpnr portable FPGA place and route tool - generic"
+arch=("any")
+url="https://github.com/YosysHQ/nextpnr"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=(
+ "yosys-nightly"
+ "python"
+ "boost-libs"
+ "qt5-base"
+)
+optdepends=()
+makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen")
+conflicts=(
+ "nextpnr-git"
+)
+replaces=()
+source=(
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=67bd349e
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+prepare() {
+ cd "${srcdir}/nextpnr"
+ [ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
+ cd ..
+}
+
+build() {
+ cd "${srcdir}/nextpnr"
+ cd build-ice40
+ cmake -G Ninja \
+ -DARCH=generic \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ cd ..
+ ninja -C build-generic
+ cd ..
+}
+
+package() {
+ cd "${srcdir}/nextpnr"
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
+ install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
+ cd ..
+}
diff --git a/PKGBUILD.in b/PKGBUILD.in
new file mode 100644
index 000000000000..fb542a8a1b8a
--- /dev/null
+++ b/PKGBUILD.in
@@ -0,0 +1,59 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=nextpnr-generic-nightly
+pkgver=@NPR_VER@
+pkgrel=1
+pkgdesc="nextpnr portable FPGA place and route tool - generic"
+arch=("any")
+url="https://github.com/YosysHQ/nextpnr"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=(
+ "yosys-nightly"
+ "python"
+ "boost-libs"
+ "qt5-base"
+)
+optdepends=()
+makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen")
+conflicts=(
+ "nextpnr-git"
+)
+replaces=()
+source=(
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=@NPR_HASH@
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+prepare() {
+ cd "${srcdir}/nextpnr"
+ [ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
+ cd ..
+}
+
+build() {
+ cd "${srcdir}/nextpnr"
+ cd build-ice40
+ cmake -G Ninja \
+ -DARCH=generic \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ cd ..
+ ninja -C build-generic
+ cd ..
+}
+
+package() {
+ cd "${srcdir}/nextpnr"
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
+ install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
+ cd ..
+}