summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Stengele2019-05-11 18:36:33 +0200
committerDennis Stengele2019-05-11 19:42:05 +0200
commit202206f4e9510e89beb06b4221966f4dfd3c3b29 (patch)
tree7312b934bbd3545df0fdb9e31d9915967ba9541b
parentb061aace3ff2f16251e8699be85085012109453b (diff)
downloadaur-202206f4e9510e89beb06b4221966f4dfd3c3b29.tar.gz
Update Beehive to 0.3.1 and mograte build to provided Makefile
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD45
-rw-r--r--beehive.install7
-rw-r--r--beehive.service3
5 files changed, 32 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ffcc1f5768a..ecd43c3dba76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
-# Generated by mksrcinfo v8
-# Sat Feb 25 14:03:07 UTC 2017
pkgbase = beehive
pkgdesc = A flexible event and agent system with lots of bees
- pkgver = 0.2
- pkgrel = 8
+ pkgver = 0.3.1
+ pkgrel = 1
url = https://github.com/muesli/beehive
+ install = beehive.install
arch = x86_64
arch = i686
license = AGPL3
makedepends = go
options = !strip
options = !emptydirs
- source = https://github.com/muesli/beehive/archive/v0.2.tar.gz
- source = beehive-admin-dist.zip::https://github.com/muesli/beehive-admin-dist/archive/e9e9a1124cf2d936e022be2371c6a5dd31f3a294.zip
+ source = beehive-0.3.1::git+https://github.com/muesli/beehive#tag=v0.3.1
source = beehive.install
source = beehive.service
- sha256sums = 6d0f2587e3b9f1ff0ae75fec58a5f49c520497f8f4a16a96b1c1ad5e0e1466b5
- sha256sums = 7a87f6960d2deab3475cf7c96646bcd83126b40abe3381aa49505b92b8036666
- sha256sums = 3c52c9a1f3115493b78958ba03fd5385c5e2fa6c8caad88318794755426330ee
- sha256sums = de07cc5b1fda921dd6ad4422651f5b81aa6393bc77c1760002e39ccd0b40c50f
+ sha256sums = SKIP
+ sha256sums = 6c6d380bd00e907b42fecb87bd07157d9e4c7806daf2f293ec9e2f9e656363c0
+ sha256sums = 0b25ced04449720cba74c0c13bc6c0b75ff6f34bcaad58889745f572f66e7160
pkgname = beehive
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a53025db3eea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.gz
+beehive-*/
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
index 864b12c8df33..3248e2a54665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,43 @@
# Maintainer: Dennis Stengele <dennis@stengele.me>
pkgname=beehive
-pkgver=0.2
-pkgrel=8
+pkgver=0.3.1
+pkgrel=1
pkgdesc="A flexible event and agent system with lots of bees"
arch=('x86_64' 'i686')
url="https://github.com/muesli/beehive"
license=('AGPL3')
makedepends=('go')
options=('!strip' '!emptydirs')
-source=("https://github.com/muesli/${pkgname}/archive/v${pkgver}.tar.gz"
- "beehive-admin-dist.zip::https://github.com/muesli/beehive-admin-dist/archive/e9e9a1124cf2d936e022be2371c6a5dd31f3a294.zip"
+install=beehive.install
+source=("$pkgname-$pkgver::git+https://github.com/muesli/beehive#tag=v$pkgver"
"beehive.install"
"beehive.service")
-sha256sums=('6d0f2587e3b9f1ff0ae75fec58a5f49c520497f8f4a16a96b1c1ad5e0e1466b5'
- '7a87f6960d2deab3475cf7c96646bcd83126b40abe3381aa49505b92b8036666'
- '3c52c9a1f3115493b78958ba03fd5385c5e2fa6c8caad88318794755426330ee'
- 'de07cc5b1fda921dd6ad4422651f5b81aa6393bc77c1760002e39ccd0b40c50f')
+sha256sums=('SKIP'
+ '6c6d380bd00e907b42fecb87bd07157d9e4c7806daf2f293ec9e2f9e656363c0'
+ '0b25ced04449720cba74c0c13bc6c0b75ff6f34bcaad58889745f572f66e7160')
-prepare() {
- cd "$pkgname-$pkgver"
- GOPATH=`pwd` go get -d -v
+build() {
+ mkdir -p gopath/src/github.com/muesli
+ ln -rTsf $pkgname-$pkgver gopath/src/github.com/muesli/$pkgname
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/muesli/$pkgname
+ make
}
-build() {
- cd "$pkgname-$pkgver"
- GOPATH=`pwd` go build
+check() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/muesli/$pkgname
+ make test
}
package() {
- cd "$pkgname-$pkgver"
-
# Install binary
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/share/webapps/beehive/$pkgname"
- # Copy assets dir
- cp -r assets "$pkgdir/usr/share/webapps/beehive/assets"
+ install -Dm755 "$pkgname-$pkgver/beehive" "$pkgdir/usr/bin/beehive"
# Copy License
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- cd ${srcdir}
+ install -Dm644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Copy Unit file
install -Dm644 beehive.service "$pkgdir/usr/lib/systemd/system/beehive.service"
-
- # Copy webinterface files
- install -dm755 "$pkgdir/usr/share/webapps/beehive/config"
- cp -r beehive-admin-dist-e9e9a1124cf2d936e022be2371c6a5dd31f3a294/* "$pkgdir/usr/share/webapps/beehive/config"
}
# vim:set ts=4 sw=4 et:
diff --git a/beehive.install b/beehive.install
index a5854464656e..d237db9e81f6 100644
--- a/beehive.install
+++ b/beehive.install
@@ -4,10 +4,8 @@ post_install() {
fi
mkdir -p /etc/beehive
chown -R beehive: /etc/beehive
- echo <<EOF
-To run a reverse proxy setup, please modify the systemd unit and add the following arguments to the ExecStart line:
- -bind ":8181" -canonicalurl "http://beehive.myhost.com"
-EOF
+ echo "To run a reverse proxy setup, please modify the systemd unit and add the following arguments to the ExecStart line:"
+ echo " -bind \":8181\" -canonicalurl \"http://beehive.myhost.com\""
}
pre_upgrade() {
@@ -18,4 +16,3 @@ post_upgrade() {
systemctl start beehive.service
}
-
diff --git a/beehive.service b/beehive.service
index 838b10c016a7..fb4cd015aea5 100644
--- a/beehive.service
+++ b/beehive.service
@@ -3,8 +3,7 @@ Description=Beehive
[Service]
User=beehive
-WorkingDirectory=/usr/share/webapps/beehive
-ExecStart=/usr/share/webapps/beehive/beehive -config /etc/beehive/beehive.conf
+ExecStart=/usr/bin/beehive -config /etc/beehive/beehive.conf
[Install]
WantedBy=multi-user.target