summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora.kudelin2020-08-26 15:01:09 +0300
committera.kudelin2020-08-26 15:01:09 +0300
commit202f00d73d7680149fb52317a71d1d8f90e3cfc6 (patch)
tree69013e6415cfc19773e4b3d2ae0b14adaf21fb5a
parent6f980850e0bd154da68965215e205014b9cefd3b (diff)
downloadaur-202f00d73d7680149fb52317a71d1d8f90e3cfc6.tar.gz
Update for GCC 10
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f39a30ee3475..8834a0210437 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octopus
pkgdesc = Real-space Time-Dependent Density Functional Theory code
pkgver = 9.2
- pkgrel = 1
+ pkgrel = 2
url = https://octopus-code.org
arch = x86_64
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index ae4db31086d9..01123467631a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=octopus
pkgver=9.2
-pkgrel=1
+pkgrel=2
pkgdesc="Real-space Time-Dependent Density Functional Theory code"
arch=('x86_64')
url="https://octopus-code.org"
@@ -18,7 +18,7 @@ prepare() {
cd "$srcdir/$pkgname-$pkgver"
autoreconf -if
export _elpaver=$( ls /usr/include | grep elpa | sed 's/elpa_openmp-//g' )
- export OPTFLAGS="-O2 -march=native -ftree-vectorize"
+ export OPTFLAGS="-O2 -march=native"
}
build() {
@@ -34,7 +34,7 @@ build() {
LIBS_ELPA="-lelpa_openmp" \
CFLAGS="$OPTFLAGS" \
CXXFLAGS="$OPTFLAGS" \
- FCFLAGS="$OPTFLAGS"
+ FCFLAGS="$OPTFLAGS -fallow-argument-mismatch -fallow-invalid-boz"
make
}