summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPig Fang2022-03-29 10:38:49 +0800
committerPig Fang2022-03-29 10:38:49 +0800
commit20352f196ef424e354fe94601a5dcc8d2e0aa8a9 (patch)
treeaa33495f26d91c7ab47143119f84e6508c31bc17
downloadaur-20352f196ef424e354fe94601a5dcc8d2e0aa8a9.tar.gz
0.9.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99fe49cbd21d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttf-martian-mono
+ pkgdesc = Free and open-source monospaced font from Evil Martians
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/evilmartians/mono
+ arch = any
+ license = OFL
+ source = https://github.com/evilmartians/mono/releases/download/v0.9.0/martian-mono-0.9.0-ttf.zip
+ source = https://raw.githubusercontent.com/evilmartians/mono/main/OFL.txt
+ sha256sums = 31f853d784c74e65a170ab93b1b3b45313eefce8249d39c0d35d048be50700eb
+ sha256sums = SKIP
+
+pkgname = ttf-martian-mono
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05f1cb24bd09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Pig Fang <g-plane@hotmail.com>
+
+pkgname=ttf-martian-mono
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='Free and open-source monospaced font from Evil Martians'
+arch=('any')
+url='https://github.com/evilmartians/mono'
+license=('OFL')
+source=("https://github.com/evilmartians/mono/releases/download/v$pkgver/martian-mono-$pkgver-ttf.zip"
+ "https://raw.githubusercontent.com/evilmartians/mono/main/OFL.txt")
+sha256sums=('31f853d784c74e65a170ab93b1b3b45313eefce8249d39c0d35d048be50700eb'
+ SKIP)
+
+package() {
+ install -d $pkgdir/usr/share/fonts/TTF
+ install -m644 *.ttf $pkgdir/usr/share/fonts/TTF/
+ install -D -m644 OFL.txt $pkgdir/usr/share/licenses/$pkgname/OFL.txt
+}