summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Hornsey2020-02-02 00:59:18 -0600
committerFrederick Hornsey2020-02-02 00:59:39 -0600
commit203743532b88796a3ffa18fa8a2303887cfb8578 (patch)
tree7ba43524393257bce700e105c8ae14757524a007
parent220356cc8566204267bed41b6aae568dcc87e180 (diff)
downloadaur-203743532b88796a3ffa18fa8a2303887cfb8578.tar.gz
3.13.3-1
- Update to OpenDDS version 3.13.3 - Switch to using DOC Group ACE/TAO (version 2.5.7) - To fix glibc 2.30 issues (see https://github.com/objectcomputing/OpenDDS/issues/1394) - Remove TAO/CCM/whatever service and patches, since they really don't have much to do with OpenDDS. - Patch Building DevGuideExamples Out - Backport fixes for installed OpenDDS from what will become 3.14. Based on these PRs: - https://github.com/objectcomputing/OpenDDS/pull/1429 - https://github.com/objectcomputing/OpenDDS/pull/1440
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD44
-rw-r--r--build.patch165
-rw-r--r--opendds.install16
-rw-r--r--tao-cosnaming.service14
6 files changed, 116 insertions, 141 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 169383490e49..629361283784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = opendds
pkgdesc = Open source C++ implementation of OMG Data Distribution Service (DDS)
- pkgver = 3.13
+ pkgver = 3.13.3
pkgrel = 1
url = http://www.opendds.org/
- install = opendds.install
arch = i686
arch = x86_64
license = custom
@@ -12,14 +11,12 @@ pkgbase = opendds
provides = ace
provides = tao
options = !buildflags
- source = http://download.ociweb.com/TAO-2.2a_patches/ACE+TAO-2.2a_p15_complete_NO_makefiles.tar.gz
- source = http://download.ociweb.com/OpenDDS/OpenDDS-3.13.tar.gz
+ source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_7/ACE+TAO-6.5.7.tar.gz
+ source = https://github.com/objectcomputing/OpenDDS/releases/download/DDS-3.13.3/OpenDDS-3.13.3.tar.gz
source = build.patch
- source = tao-cosnaming.service
- md5sums = 2ccae8afe84ef9978cb6a1ab21b91402
- md5sums = 0ff8fed7b1590f460ca0d6ae3de219ec
- md5sums = d8dda850a09ba6ba621be2eef7bc9329
- md5sums = 63fba1c486fb3ed8b216e0b456b50988
+ md5sums = b0a66007920a1bb591ae6d458954c136
+ md5sums = 35a0907fd6d6b9c29a5c4718e8c35624
+ md5sums = f3eaf93bc0986b7da69ab9dbae0c8aad
pkgname = opendds
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dca3572c3570
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/*.tar.*
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
index 4638784f1195..ae83ca8549ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
#
pkgname=opendds
_pkgname=OpenDDS
-pkgver=3.13
+pkgver=3.13.3
pkgrel=1
-_oci_ace_tao_patch=15
+_ace_tao_version=6.5.7
pkgdesc="Open source C++ implementation of OMG Data Distribution Service (DDS)"
arch=('i686' 'x86_64')
url="http://www.opendds.org/"
@@ -13,53 +13,37 @@ license=('custom')
depends=('perl' 'bash')
provides=('ace' 'tao')
options=('!buildflags')
-install=opendds.install
source=(
- "http://download.ociweb.com/TAO-2.2a_patches/ACE+TAO-2.2a_p${_oci_ace_tao_patch}_complete_NO_makefiles.tar.gz"
- "http://download.ociweb.com/OpenDDS/OpenDDS-$pkgver.tar.gz"
+ "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-$(echo $_ace_tao_version | sed -e 's/\./_/g')/ACE+TAO-$_ace_tao_version.tar.gz"
+ "https://github.com/objectcomputing/OpenDDS/releases/download/DDS-$pkgver/OpenDDS-$pkgver.tar.gz"
build.patch
- tao-cosnaming.service
-)
-md5sums=(
- # ACE+TAO-2.2a_pPATCH_complete_NO_makefiles.tar.gz
- '2ccae8afe84ef9978cb6a1ab21b91402'
- # OpenDDS-VERSION.tar.gz
- '0ff8fed7b1590f460ca0d6ae3de219ec'
- # build.patch
- 'd8dda850a09ba6ba621be2eef7bc9329'
- # tao-cosnaming.service
- '63fba1c486fb3ed8b216e0b456b50988'
)
+md5sums=('b0a66007920a1bb591ae6d458954c136'
+ '35a0907fd6d6b9c29a5c4718e8c35624'
+ 'f3eaf93bc0986b7da69ab9dbae0c8aad')
prepare() {
cd "$srcdir"
mv "OpenDDS-$pkgver" OpenDDS
- patch -Np1 -b -z .orig -i ../build.patch
+ patch --strip=1 -i ../build.patch
}
build() {
cd "$srcdir/OpenDDS"
- ACE_ROOT="$srcdir/ACE_wrappers" \
- TAO_ROOT="$ACE_ROOT/TAO" \
- MPC_ROOT="$ACE_ROOT/MPC" \
./configure \
- --prefix="/usr" \
+ --ace="$srcdir/ACE_wrappers" \
--no-tests
make
}
package() {
- source "$srcdir/OpenDDS/setenv.sh"
- cd "$DDS_ROOT"
+ cd "$srcdir/OpenDDS"
+ source setenv.sh
make INSTALL_PREFIX="/usr" DESTDIR="$pkgdir" install
cd "$srcdir"
- install -Dm644 ACE_wrappers/rpmbuild/etc/tao/tao-cosnaming.conf "$pkgdir/etc/tao/tao-cosnaming.conf"
- install -Dm644 ACE_wrappers/rpmbuild/ace-tao-init-fedora/tao/tao-cosnaming.opt "$pkgdir/etc/tao/tao-cosnaming.opt"
- install -Dm644 tao-cosnaming.service "$pkgdir/usr/lib/systemd/system/tao-cosnaming.service"
- install -dm755 "$pkgdir/usr/lib/tmpfiles.d"
- printf 'd /run/tao 0750 tao tao\n' >"$pkgdir/usr/lib/tmpfiles.d/tao.conf"
- install -Dm644 "$DDS_ROOT/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/opendds_LICENSE"
- install -Dm644 ACE_wrappers/COPYING "$pkgdir/usr/share/licenses/$pkgname/acetao_LICENSE"
+ install -Dm644 "$DDS_ROOT/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/OpenDDS_LICENSE"
+ install -Dm644 ACE_wrappers/COPYING "$pkgdir/usr/share/licenses/$pkgname/ACE_TAO_LICENSE"
+ # TODO Other licences
}
# vim:set ts=2 sw=2 et:
diff --git a/build.patch b/build.patch
index fcf9dfd4fda6..3497610ebbd5 100644
--- a/build.patch
+++ b/build.patch
@@ -1,101 +1,122 @@
-diff -up src/ACE_wrappers/TAO/CIAO/ccm/CCM_stub.mpc.orig src/ACE_wrappers/TAO/CIAO/ccm/CCM_stub.mpc
---- src/ACE_wrappers/TAO/CIAO/ccm/CCM_stub.mpc.orig 2014-09-25 02:05:52.000000000 -0600
-+++ src/ACE_wrappers/TAO/CIAO/ccm/CCM_stub.mpc 2014-09-25 02:06:05.000000000 -0600
-@@ -140,7 +140,7 @@ project(CCM_stub) : install, ciaolib_wit
- }
+--- src/OpenDDS/DDS_TAOv2.mwc.1
++++ src/OpenDDS/DDS_TAOv2.mwc
+@@ -24,7 +24,6 @@ workspace {
+ dds
+ tools
+ java
+- DevGuideExamples
- verbatim(gnuace, postinstall) {
--" $(MKDIR) $(INSTALL_PREFIX)/share/ciao/ccm"
--" ln -sf $(INSTALL_PREFIX)/include/ccm/Components.idl $(INSTALL_PREFIX)/share/ciao/ccm"
-+" $(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ciao/ccm"
-+" ln -sf $(INSTALL_PREFIX)/include/ccm/Components.idl $(DESTDIR)$(INSTALL_PREFIX)/share/ciao/ccm"
- }
- }
-diff -up src/ACE_wrappers/TAO/CIAO/connectors/dds4ccm/idl/ndds/ndds_idltocpp_stub.mpc.orig src/ACE_wrappers/TAO/CIAO/connectors/dds4ccm/idl/ndds/ndds_idltocpp_stub.mpc
---- src/ACE_wrappers/TAO/CIAO/connectors/dds4ccm/idl/ndds/ndds_idltocpp_stub.mpc.orig 2014-09-25 02:10:36.000000000 -0600
-+++ src/ACE_wrappers/TAO/CIAO/connectors/dds4ccm/idl/ndds/ndds_idltocpp_stub.mpc 2014-09-25 02:11:06.000000000 -0600
-@@ -22,7 +22,7 @@ project (CIAO_NDDS_idl_gen) : install, n
+ exclude {
+ java/jms
+--- src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc
++++ src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc
+@@ -42,7 +42,8 @@
+ " ln -sf $(INSTALL_PREFIX)/bin/tao_idl $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
+ "ifeq ($(shared_libs),1)"
+ " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
+-" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_[FB]E.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
++" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_FE.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
++" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_BE.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
+ "endif"
}
- verbatim(gnuace, postinstall) {
--" cp ndds_dcps_instance_handle.idl $(INSTALL_PREFIX)/include/connectors/dds4ccm/idl/ndds/"
-+" cp ndds_dcps_instance_handle.idl $(DESTDIR)$(INSTALL_PREFIX)/include/connectors/dds4ccm/idl/ndds/"
+--- src/OpenDDS/dds/DdsDcps.mpc
++++ src/OpenDDS/dds/DdsDcps.mpc
+@@ -80,15 +80,10 @@ project(OpenDDS_Dcps): core, coverage_optional, \
+ ../rules.dds.GNU
}
- }
-@@ -68,8 +68,8 @@ project (CIAO_NDDS_idl_install_only) {
+- InstallData_Files {
+- gendir = bin
+- ../bin/PerlDDS
+- }
+-
+ verbatim(gnuace, postinstall) {
+-" echo export DDS_ROOT=$(DESTDIR)$(INSTALL_PREFIX)/share/dds> $(DESTDIR)$(INSTALL_PREFIX)/share/dds/dds-devel.sh"
++" echo export DDS_ROOT=$(INSTALL_PREFIX)/share/dds> $(DESTDIR)$(INSTALL_PREFIX)/share/dds/dds-devel.sh"
+ " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/dds/dds"
+-" ln -sf $(DESTDIR)$(INSTALL_PREFIX)/include/dds/Version.h $(DESTDIR)$(INSTALL_PREFIX)/share/dds/dds"
++" ln -sf $(INSTALL_PREFIX)/include/dds/Version.h $(DESTDIR)$(INSTALL_PREFIX)/share/dds/dds"
+ " cp $(DDS_ROOT)/user_macros.GNU $(DESTDIR)$(INSTALL_PREFIX)/share/dds $(ACE_NUL_STDERR)"
+ " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/$(INSTALL_LIB)/cmake/OpenDDS"
+ " cp $(DDS_ROOT)/cmake/*.cmake $(DESTDIR)$(INSTALL_PREFIX)/$(INSTALL_LIB)/cmake/OpenDDS"
+--- src/OpenDDS/dds/idl/opendds_idl.mpc
++++ src/OpenDDS/dds/idl/opendds_idl.mpc
+@@ -35,7 +35,7 @@ project: aceexe, dds_macros, crosscompile, install {
- verbatim(gnuace, bottom) {
- "install:"
--" $(MKDIR) $(INSTALL_PREFIX)/share/ciao/connectors/dds4ccm/idl/ndds"
--" cp *.idl $(INSTALL_PREFIX)/share/ciao/connectors/dds4ccm/idl/ndds"
-+" $(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ciao/connectors/dds4ccm/idl/ndds"
-+" cp *.idl $(DESTDIR)$(INSTALL_PREFIX)/share/ciao/connectors/dds4ccm/idl/ndds"
+ verbatim(gnuace, postinstall) {
+ " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/dds/bin"
+-" ln -sf $(DESTDIR)$(INSTALL_PREFIX)/bin/opendds_idl $(DESTDIR)$(INSTALL_PREFIX)/share/dds/bin"
++" ln -sf $(INSTALL_PREFIX)/bin/opendds_idl $(DESTDIR)$(INSTALL_PREFIX)/share/dds/bin"
}
}
-diff -up src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_IDL2/IDL3_to_IDL2.mpc.orig src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_IDL2/IDL3_to_IDL2.mpc
---- src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_IDL2/IDL3_to_IDL2.mpc.orig 2014-09-25 02:12:05.000000000 -0600
-+++ src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_IDL2/IDL3_to_IDL2.mpc 2014-09-25 02:12:12.000000000 -0600
-@@ -69,7 +69,7 @@ project(TAO_IDL3_TO_IDL2_EXE) : aceexe,
+--- src/OpenDDS/java/dds/dcps_java.mpc
++++ src/OpenDDS/java/dds/dcps_java.mpc
+@@ -112,6 +112,6 @@ project: idl2jni, javah, dcpslib, optional_jni_check, dcps_java_optional, dcps_t
+ " cp $(DDS_ROOT)/lib/OpenDDS_DCPS.jar $(INSTALL_PREFIX)/lib"
+ " perl -pi -e 's!\\$$[(]DDS_ROOT[)]/lib!$(INSTALL_PREFIX)/lib!g' $(DESTDIR)$(INSTALL_PREFIX)/share/dds/MPC/config/idl2jni.mpb"
+ " perl -pi -e 's!\\$$[(]DDS_ROOT[)]/lib!$(INSTALL_PREFIX)/lib!g' $(DESTDIR)$(INSTALL_PREFIX)/share/dds/MPC/config/dcps_java.mpb"
+-" rm $(INSTALL_PREFIX)/dds/*.idl && rmdir $(INSTALL_PREFIX)/dds"
++" rm $(DESTDIR)$(INSTALL_PREFIX)/dds/*.idl && rmdir $(DESTDIR)$(INSTALL_PREFIX)/dds"
+ }
+ }
+--- src/OpenDDS/java/dds/dcps_java.mpc
++++ src/OpenDDS/java/dds/dcps_java.mpc
+@@ -109,7 +109,7 @@ project: idl2jni, javah, dcpslib, optional_jni_check, dcps_java_optional, dcps_t
}
verbatim(gnuace, postinstall) {
--" @$(MKDIR) $(INSTALL_PREFIX)/share/ace/bin"
--" ln -sf $(INSTALL_PREFIX)/bin/tao_idl3_to_idl2 $(INSTALL_PREFIX)/share/ace/bin"
-+" @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
-+" ln -sf $(INSTALL_PREFIX)/bin/tao_idl3_to_idl2 $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
- }
- }
-diff -up src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_XMI/IDL3_TO_XMI.mpc.orig src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_XMI/IDL3_TO_XMI.mpc
---- src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_XMI/IDL3_TO_XMI.mpc.orig 2014-09-25 02:11:33.000000000 -0600
-+++ src/ACE_wrappers/TAO/CIAO/tools/IDL3_to_XMI/IDL3_TO_XMI.mpc 2014-09-25 02:11:44.000000000 -0600
-@@ -64,7 +64,7 @@ project(CIAO_IDL3_TO_XMI_EXE) : aceexe,
+-" cp $(DDS_ROOT)/lib/OpenDDS_DCPS.jar $(INSTALL_PREFIX)/lib"
++" cp $(DDS_ROOT)/lib/OpenDDS_DCPS.jar $(DESTDIR)$(INSTALL_PREFIX)/lib"
+ " perl -pi -e 's!\\$$[(]DDS_ROOT[)]/lib!$(INSTALL_PREFIX)/lib!g' $(DESTDIR)$(INSTALL_PREFIX)/share/dds/MPC/config/idl2jni.mpb"
+ " perl -pi -e 's!\\$$[(]DDS_ROOT[)]/lib!$(INSTALL_PREFIX)/lib!g' $(DESTDIR)$(INSTALL_PREFIX)/share/dds/MPC/config/dcps_java.mpb"
+ " rm $(DESTDIR)$(INSTALL_PREFIX)/dds/*.idl && rmdir $(DESTDIR)$(INSTALL_PREFIX)/dds"
+--- src/OpenDDS/java/idl2jni/codegen/idl2jni_codegen.mpc
++++ src/OpenDDS/java/idl2jni/codegen/idl2jni_codegen.mpc
+@@ -22,7 +22,7 @@ project: aceexe, crosscompile, dds_macros, install {
}
verbatim(gnuace, postinstall) {
--" @$(MKDIR) $(INSTALL_PREFIX)/share/ace/bin"
--" ln -sf $(INSTALL_PREFIX)/bin/tao_idl3_to_xmi $(INSTALL_PREFIX)/share/ace/bin"
-+" @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
-+" ln -sf $(INSTALL_PREFIX)/bin/tao_idl3_to_xmi $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
+-" @$(MKDIR) $(INSTALL_PREFIX)/share/dds/bin"
+-" ln -sf $(INSTALL_PREFIX)/bin/idl2jni $(INSTALL_PREFIX)/share/dds/bin"
++" @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/dds/bin"
++" ln -sf $(INSTALL_PREFIX)/bin/idl2jni $(DESTDIR)$(INSTALL_PREFIX)/share/dds/bin"
}
}
-diff -up src/ACE_wrappers/TAO/DAnCE/dance/DAnCE_Properties.mpc.orig src/ACE_wrappers/TAO/DAnCE/dance/DAnCE_Properties.mpc
---- src/ACE_wrappers/TAO/DAnCE/dance/DAnCE_Properties.mpc.orig 2014-09-25 02:14:45.000000000 -0600
-+++ src/ACE_wrappers/TAO/DAnCE/dance/DAnCE_Properties.mpc 2014-09-25 02:15:27.000000000 -0600
-@@ -24,8 +24,8 @@ project(DAnCE_Properties_IDL) : install,
+--- src/OpenDDS/java/idl2jni/compact/idl2jni_compact.mpc
++++ src/OpenDDS/java/idl2jni/compact/idl2jni_compact.mpc
+@@ -13,6 +13,6 @@ project: java, dds_macros, install {
}
verbatim(gnuace, postinstall) {
--" cp ../rules.dance.GNU $(INSTALL_PREFIX)/share/dance"
--" perl -i -pe's!\\$$[{(]DANCE_ROOT[})]!$(INSTALL_PREFIX)/include!g;' $(INSTALL_PREFIX)/share/dance/rules.dance.GNU"
--" echo export DANCE_ROOT=$(INSTALL_PREFIX)/share/dance> $(INSTALL_PREFIX)/share/dance/dance-devel.sh"
-+" cp ../rules.dance.GNU $(DESTDIR)$(INSTALL_PREFIX)/share/dance"
-+" perl -i -pe's!\\$$[{(]DANCE_ROOT[})]!$(INSTALL_PREFIX)/include!g;' $(DESTDIR)$(INSTALL_PREFIX)/share/dance/rules.dance.GNU"
-+" echo export DANCE_ROOT=$(INSTALL_PREFIX)/share/dance> $(DESTDIR)$(INSTALL_PREFIX)/share/dance/dance-devel.sh"
+-" cp $(DDS_ROOT)/lib/i2jrt_compact.jar $(INSTALL_PREFIX)/lib"
++" cp $(DDS_ROOT)/lib/i2jrt_compact.jar $(DESTDIR)$(INSTALL_PREFIX)/lib"
}
}
-diff -up src/ACE_wrappers/TAO/DAnCE/dance/LocalityManager/Daemon/Locality_Manager.mpc.orig src/ACE_wrappers/TAO/DAnCE/dance/LocalityManager/Daemon/Locality_Manager.mpc
---- src/ACE_wrappers/TAO/DAnCE/dance/LocalityManager/Daemon/Locality_Manager.mpc.orig 2014-09-25 02:14:07.000000000 -0600
-+++ src/ACE_wrappers/TAO/DAnCE/dance/LocalityManager/Daemon/Locality_Manager.mpc 2014-09-25 02:14:15.000000000 -0600
-@@ -34,6 +34,6 @@ project (DAnCE_LocalityManager_Exec) : d
+--- src/OpenDDS/java/idl2jni/runtime/idl2jni_runtime.mpc
++++ src/OpenDDS/java/idl2jni/runtime/idl2jni_runtime.mpc
+@@ -24,9 +24,9 @@ project: taolib, java, javah, optional_jni_check, dds_macros, i2jrt_optional, in
}
verbatim(gnuace, postinstall) {
--" cp Locality_Manager_Task.cpp Locality_Manager.cpp Locality_Manager_Task.h $(INSTALL_PREFIX)/include/dance/LocalityManager/Daemon"
-+" cp Locality_Manager_Task.cpp Locality_Manager.cpp Locality_Manager_Task.h $(DESTDIR)$(INSTALL_PREFIX)/include/dance/LocalityManager/Daemon"
+-" cp $(DDS_ROOT)/lib/i2jrt.jar $(INSTALL_PREFIX)/lib"
+-" @$(MKDIR) $(INSTALL_PREFIX)/share/dds/java/build_scripts"
+-" cp ../../build_scripts/java?_wrapper.pl $(INSTALL_PREFIX)/share/dds/java/build_scripts"
+-" cp *.h $(INSTALL_PREFIX)/share/dds/java"
++" cp $(DDS_ROOT)/lib/i2jrt.jar $(DESTDIR)$(INSTALL_PREFIX)/lib"
++" @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/dds/java/build_scripts"
++" cp ../../build_scripts/java?_wrapper.pl $(DESTDIR)$(INSTALL_PREFIX)/share/dds/java/build_scripts"
++" cp *.h $(DESTDIR)$(INSTALL_PREFIX)/share/dds/java"
}
}
-diff -up src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc.orig src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc
---- src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc.orig 2014-09-25 02:13:01.000000000 -0600
-+++ src/ACE_wrappers/TAO/TAO_IDL/tao_idl.mpc 2014-09-25 02:13:33.000000000 -0600
-@@ -36,7 +36,8 @@ project(TAO_IDL_EXE) : aceexe, install,
- " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
- " ln -sf $(INSTALL_PREFIX)/bin/tao_idl $(DESTDIR)$(INSTALL_PREFIX)/share/ace/bin"
- " @$(MKDIR) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
--" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_[FB]E.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
-+" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_FE.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
-+" ln -sf $(INSTALL_PREFIX)/$(INSTALL_LIB)/$(LIB_PREFIX)TAO_IDL_BE.$(SOEXT) $(DESTDIR)$(INSTALL_PREFIX)/share/ace/lib"
+--- src/OpenDDS/java/tao/tao_java.mpc
++++ src/OpenDDS/java/tao/tao_java.mpc
+@@ -34,6 +34,6 @@ project: taolib, idl2jni, install {
}
- Source_Files {
+ verbatim(gnuace, postinstall) {
+-" cp $(DDS_ROOT)/lib/tao_java.jar $(INSTALL_PREFIX)/lib"
++" cp $(DDS_ROOT)/lib/tao_java.jar $(DESTDIR)$(INSTALL_PREFIX)/lib"
+ }
+ }
diff --git a/opendds.install b/opendds.install
deleted file mode 100644
index c2983adee690..000000000000
--- a/opendds.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install(){
- # new password and equal group allocated in system range
- usr/bin/getent passwd tao >/dev/null 2>&1 || \
- usr/bin/useradd -K SYS_UID_MIN=100 -K SYS_UID_MAX=499 \
- -K SYS_GID_MIN=100 -K SYS_GID_MAX=499 \
- -K USERGROUPS_ENAB=yes -r -U -d /run/tao -s /bin/false tao
- true
-}
-
-post_remove(){
- usr/bin/getent passwd tao >/dev/null 2>&1 && usr/bin/userdel tao
- usr/bin/getent group tao >/dev/null 2>&1 && usr/bin/groupdel tao
- true
-}
-
-# vim:set ts=2 sw=2 ft=sh et:
diff --git a/tao-cosnaming.service b/tao-cosnaming.service
deleted file mode 100644
index e5f46bc79442..000000000000
--- a/tao-cosnaming.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=TAO Naming Service
-After=network.target
-
-[Service]
-Type=forking
-PIDFile=/run/tao/tao-cosnaming.pid
-EnvironmentFile=/etc/tao/tao-cosnaming.opt
-User=tao
-Group=tao
-ExecStart=/usr/bin/tao_cosnaming -p /run/tao/tao-cosnaming.pid $OPTIONS -ORBSvcConf /etc/tao/tao-cosnaming.conf -ORBDaemon
-
-[Install]
-WantedBy=multi-user.target