summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortech2019-12-02 16:24:07 +0100
committertech2019-12-02 16:24:07 +0100
commit2037492307677cb81e1259ccf34bd35d0a8409bc (patch)
tree8d840d32068a8f51750e48506fed81f4a4029aaa
parent07b8406a4bd4e7bb55c09abbb2f3a14ebc5cf8b7 (diff)
downloadaur-2037492307677cb81e1259ccf34bd35d0a8409bc.tar.gz
fixed build with the helpful input of yochananmarqos
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da6eb8b92d14..6241bea5fbf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = arch-sec-check-git
pkgdesc = Compares your local installed packages with the arch linux security database
- pkgver = 1.1
+ pkgver = r11.ecc5bc7
pkgrel = 1
url = https://gitlab.com/techfreak/arch-sec-check
arch = any
license = GPL2
makedepends = git
- makedepends = cargo
makedepends = rust
depends = openssl
+ provides = arch-sec-check
+ conflicts = arch-sec-check
source = git+https://gitlab.com/techfreak/arch-sec-check.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 015d54a8e58f..387a8d11f503 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: techfreak <techfreak@matrix.org>
pkgname=arch-sec-check-git
-pkgver=1.1
+pkgver=r11.ecc5bc7
pkgrel=1
pkgdesc="Compares your local installed packages with the arch linux security database"
arch=(any)
url="https://gitlab.com/techfreak/arch-sec-check"
license=(GPL2)
depends=(openssl)
-makedepends=(git cargo rust)
+makedepends=(git rust)
optdepends=()
source=("git+${url}.git")
sha256sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd ${pkgname}
- cargo build --release
+ cd ${pkgname%-git}
+ cargo build --release --locked
}
package() {
- cd ${pkgname}
- install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${pkgname%-git}
+ install -Dm755 "target/release/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
}