summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryesuu2015-06-12 00:43:10 +0800
committeryesuu2015-06-12 00:43:10 +0800
commit2055421fe268b1c2abf69f753ccbf4f7a0b9ad0a (patch)
tree6602a8c2b3a91c0094fbd5b9e52798a498d6a0c5
downloadaur-2055421fe268b1c2abf69f753ccbf4f7a0b9ad0a.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aa10573001c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gocode-git
+ pkgdesc = An autocompletion daemon for the Go programming language
+ pkgver = 637.10c1e59
+ pkgrel = 1
+ url = https://github.com/nsf/gocode
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = go
+ optdepends = auto-complete: emacs autocompletion
+ source = git+https://github.com/nsf/gocode
+ md5sums = SKIP
+
+pkgname = gocode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f77b094771d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Contributor: Daniel YC Lin <dlin.tw at> gmail.com>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Dave Reisner <d@falconindy.com>
+
+pkgname=gocode-git
+pkgver=637.10c1e59
+pkgrel=1
+pkgdesc="An autocompletion daemon for the Go programming language"
+arch=('i686' 'x86_64')
+url="https://github.com/nsf/gocode"
+license=('MIT')
+depends=('go')
+makedepends=('git')
+optdepends=('auto-complete: emacs autocompletion')
+source=('git+https://github.com/nsf/gocode')
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/gocode"
+ go build -o gocode
+}
+
+package() {
+ cd "${srcdir}/gocode"
+ install -Dm755 gocode "${pkgdir}/usr/bin/gocode"
+ install --directory "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r vim/autoload "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r vim/ftplugin "${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 emacs/go-autocomplete.el "${pkgdir}/usr/share/emacs/site-lisp/go-autocomplete.el"
+}