summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-09-27 13:53:47 +0800
committerUniversebenzene2023-09-27 13:53:47 +0800
commit205ee4061b180aba800424be0756b99b6cb72488 (patch)
treefb5980d8f7e839141495c0670b2d03e2db28ed57
parent70f5b7f94f399e00d9f5263ce7cb2b433e33b4bc (diff)
downloadaur-205ee4061b180aba800424be0756b99b6cb72488.tar.gz
Update to version 2023.9.26
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7de1f0913eba..1b2a3c45f052 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2023.9.18
+ pkgver = 2023.9.26
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -10,8 +10,8 @@ pkgbase = python-tifffile
makedepends = python-setuptools
makedepends = python-sphinx
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2023.9.18.tar.gz
- sha256sums = 391d49e5e10a0f50f627b9083116f965e37d40bfe4e4713154e5edd57591590c
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2023.9.26.tar.gz
+ sha256sums = 67e355e4595aab397f8405d04afe1b4ae7c6f62a44e22d933fee1a571a48c7ae
pkgname = python-tifffile
depends = python-numpy>=1.25.2
@@ -19,7 +19,7 @@ pkgname = python-tifffile
optdepends = python-imagecodecs>=2023.9.4: required for encoding or decoding LZW, JPEG, etc. compressed segments
optdepends = python-lxml>=4.9.2: required only for validating and printing XML
optdepends = python-zarr>=2.16.0: required for opening Zarr stores
- optdepends = python-fsspec>=2023.6.0: required only for opening ReferenceFileSystem files
+ optdepends = python-fsspec>=2023.9.2: required only for opening ReferenceFileSystem files
optdepends = python-tifffile-doc: Documentation for Python tifffile
pkgname = python-tifffile-doc
diff --git a/PKGBUILD b/PKGBUILD
index 56045b9685d2..e928878ccccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=python-tifffile
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2023.9.18
+pkgver=2023.9.26
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
@@ -18,7 +18,7 @@ checkdepends=('python-pytest'
'python-imagecodecs') # numpy ? xarray
# 'python-fsspec'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('391d49e5e10a0f50f627b9083116f965e37d40bfe4e4713154e5edd57591590c')
+sha256sums=('67e355e4595aab397f8405d04afe1b4ae7c6f62a44e22d933fee1a571a48c7ae')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -60,7 +60,7 @@ package_python-tifffile() {
'python-imagecodecs>=2023.9.4: required for encoding or decoding LZW, JPEG, etc. compressed segments'
'python-lxml>=4.9.2: required only for validating and printing XML'
'python-zarr>=2.16.0: required for opening Zarr stores'
- 'python-fsspec>=2023.6.0: required only for opening ReferenceFileSystem files'
+ 'python-fsspec>=2023.9.2: required only for opening ReferenceFileSystem files'
'python-tifffile-doc: Documentation for Python tifffile')
cd ${srcdir}/${_pyname}-${pkgver}