summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-09 05:56:56 +0200
committerDimitris Kiziridis2020-03-09 05:56:56 +0200
commit20aad4bd280d65a9a928e6ad602ef5a7e8e013ac (patch)
treefc5190d3b9b0312c6ddda4e9d8339c39781dc96c
parentcbe230fdf9dcac14d529d4fcc95c5e6eca460913 (diff)
downloadaur-20aad4bd280d65a9a928e6ad602ef5a7e8e013ac.tar.gz
Update to 2.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD70
2 files changed, 30 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b19a0e7ff6c9..9c79ad7ce605 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = storm
- pkgdesc = Free and open source distributed realtime computation system
- pkgver = 1.2.2
- pkgrel = 2
+ pkgdesc = Apache Storm is a free and open source distributed realtime computation system
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://storm.apache.org/
install = install_storm.sh
arch = any
license = Apache
+ makedepends = jq
depends = java-runtime
depends = python2
depends = zookeeper
+ provides = apache-storm
backup = etc/storm/storm_env.ini
backup = etc/storm/storm.yaml
backup = etc/zookeeper/zookeeper-storm/zoo.cfg
backup = etc/zookeeper/zookeeper-storm/log4j.properties
- source = http://apache.crihan.fr/dist///storm/apache-storm-1.2.2/apache-storm-1.2.2.tar.gz
- source = https://www.apache.org/dist/storm/apache-storm-1.2.2/apache-storm-1.2.2.tar.gz.asc
+ source = http://apache.otenet.gr/dist/storm/apache-storm-2.1.0/apache-storm-2.1.0.tar.gz
source = zookeeper_zoo.cfg
source = zookeeper_log4j.properties
source = systemd_storm-nimbus.service
@@ -22,10 +23,7 @@ pkgbase = storm
source = systemd_storm-ui.service
source = systemd_sysusers.d_storm.conf
source = systemd_tmpfiles.d_storm.conf
- source = arch_python2.patch
- validpgpkeys = ACEFE18DD2322E1E84587A148DE03962E80B8FFD
- sha256sums = e97e92ea13998c95ee37565bdf4d6f6a379deb259ec76cb0178cd356502e657f
- sha256sums = SKIP
+ sha256sums = e279a495dda42af7d9051543989f74a1435a5bda53e795a1de4a1def32027fc4
sha256sums = c94799f4b459f5218faf1da57936baeb4c32b9542a1ba0aacdd637bf2f3aaf05
sha256sums = 00780ee4cea3bb7a282a548f41b8964d5e392776f9d687ebea89cd49ed5742e3
sha256sums = 2dafe9352ed01fbe0c74ec6e29e0233a842c4fead7af38cd3540bf69c93a895c
@@ -33,7 +31,6 @@ pkgbase = storm
sha256sums = a27a90bae3d948a6cf65732c43b92c735f8dbaa707ab7dfd9f7c74e4fe42f3ba
sha256sums = 66db40103bc75bae0817581ef1bbde35bb3b81c2494eda5a8c769813ddd000f1
sha256sums = 15c959356f32c9583fe6a328d2ec4c7addb983ac7a2529621d90c24b49a07df3
- sha256sums = 94567fe94f4d27b1a82714231c0fa9a87827343f3838f9a962e3483f6c6d26a5
pkgname = storm
diff --git a/PKGBUILD b/PKGBUILD
index 970b4ed87e88..0691ce797f3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,7 @@
-# Maintainer: Bram Vereertbrugghen <bramvereertbrugghen at live dot be>
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Bram Vereertbrugghen <bramvereertbrugghen at live dot be>
# Contributor: Guillaume ALAUX <guillaume at alaux dot net>
-# Important note about source signature validation:
-#
-# `makepkg` will refuse to build this package unless you either:
-#
-# - manually add upstream signing key to your GPG keyring with:
-# `gpg --recv-keys <UPSTREAM_KEY(S)>`
-# - set your GPG config to automatically retrieve missing keys by adding
-# `keyserver-options auto-key-retrieve` to your `~/.gnupg/gpg.conf`
-#
-# Whichever you choose **will not sign nor trust** the downloaded key(s)
-# and will thus **not** affect security checks of your keyring in any way.
-# On the other hand the provided `validpgpkeys` directive will allow `makepkg`
-# to trust the given key(s) for this package build as **I**, the package
-# provider, have checked these keys are bound to actual upstream accounts.
-
# nimbus -> requires zookeeper to run
# supervisor -> requires zookeeper to run
# ui -> requires nimbus
@@ -24,45 +10,38 @@
# TODO split packages? nimbus/supervisor/ui ?
pkgname=storm
-# pkgver=1.0.2
-pkgver=1.2.2
-pkgrel=2
-pkgdesc='Free and open source distributed realtime computation system'
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Apache Storm is a free and open source distributed realtime computation system'
arch=('any')
url='https://storm.apache.org/'
license=('Apache')
depends=('java-runtime' 'python2' 'zookeeper')
-backup=(etc/storm/storm_env.ini
- etc/storm/storm.yaml
- etc/zookeeper/zookeeper-storm/zoo.cfg
- etc/zookeeper/zookeeper-storm/log4j.properties)
+makedepends=('jq')
+provides=('apache-storm')
+backup=('etc/storm/storm_env.ini'
+ 'etc/storm/storm.yaml'
+ 'etc/zookeeper/zookeeper-storm/zoo.cfg'
+ 'etc/zookeeper/zookeeper-storm/log4j.properties')
install=install_storm.sh
-
-_apache_cgi="http://www.apache.org/dyn/closer.cgi"
-_closest=$(curl "${_apache_cgi}?asjson=1" | tr -d '\n ' | sed -r 's/.*"preferred":"(.+)".*/\1/')
-_app_path="/${pkgname}/apache-${pkgname}-${pkgver}/apache-${pkgname}-${pkgver}.tar.gz"
-source=(${_closest}/${_app_path}
- https://www.apache.org/dist/${pkgname}/apache-${pkgname}-${pkgver}/apache-${pkgname}-${pkgver}.tar.gz.asc
- zookeeper_zoo.cfg
- zookeeper_log4j.properties
- systemd_storm-nimbus.service
- systemd_storm-supervisor.service
- systemd_storm-ui.service
- systemd_sysusers.d_storm.conf
- systemd_tmpfiles.d_storm.conf
- arch_python2.patch)
-validpgpkeys=('ACEFE18DD2322E1E84587A148DE03962E80B8FFD') # P. Taylor Goetz
-
-sha256sums=('e97e92ea13998c95ee37565bdf4d6f6a379deb259ec76cb0178cd356502e657f'
- 'SKIP'
+_download_portal="https://www.apache.org/dyn/closer.lua/storm/apache-storm-${pkgver}/apache-storm-${pkgver}.tar.gz"
+_closest_mirror=$(curl "${_download_portal}?asjson=1" | jq '(.preferred + .path_info)' | tr -d '"",' )
+source=("$_closest_mirror"
+ 'zookeeper_zoo.cfg'
+ 'zookeeper_log4j.properties'
+ 'systemd_storm-nimbus.service'
+ 'systemd_storm-supervisor.service'
+ 'systemd_storm-ui.service'
+ 'systemd_sysusers.d_storm.conf'
+ 'systemd_tmpfiles.d_storm.conf')
+sha256sums=('e279a495dda42af7d9051543989f74a1435a5bda53e795a1de4a1def32027fc4'
'c94799f4b459f5218faf1da57936baeb4c32b9542a1ba0aacdd637bf2f3aaf05'
'00780ee4cea3bb7a282a548f41b8964d5e392776f9d687ebea89cd49ed5742e3'
'2dafe9352ed01fbe0c74ec6e29e0233a842c4fead7af38cd3540bf69c93a895c'
'5decdfb42d6f1b50c21df1c36072bf1c97d0553a23c29536ea020a31210535ce'
'a27a90bae3d948a6cf65732c43b92c735f8dbaa707ab7dfd9f7c74e4fe42f3ba'
'66db40103bc75bae0817581ef1bbde35bb3b81c2494eda5a8c769813ddd000f1'
- '15c959356f32c9583fe6a328d2ec4c7addb983ac7a2529621d90c24b49a07df3'
- '94567fe94f4d27b1a82714231c0fa9a87827343f3838f9a962e3483f6c6d26a5')
+ '15c959356f32c9583fe6a328d2ec4c7addb983ac7a2529621d90c24b49a07df3')
package() {
cd "${srcdir}/apache-${pkgname}-${pkgver}"
@@ -83,8 +62,6 @@ package() {
sed -i "1s|^#!/usr/bin/python$|#!/usr/bin/python2|" \
"${pkgdir}${_app_home}/bin/storm.py"
ln -s ${_app_home}/bin/storm "${pkgdir}/usr/bin/storm"
- patch -d "${pkgdir}${_app_home}" \
- -p0 < "${srcdir}/arch_python2.patch"
cp -r lib/* "${pkgdir}/usr/share/java/${pkgname}"
ln -s ../java/${pkgname} "${pkgdir}${_app_home}/lib"
@@ -100,7 +77,6 @@ package() {
>> "${pkgdir}/etc/${pkgname}/storm.yaml"
echo "storm.local.dir: \"/var/lib/${pkgname}\"" \
>> "${pkgdir}/etc/${pkgname}/storm.yaml"
- #TODO dev-storm-zookeeper (add this in conjunction with special storm-zookeeper.service file?)
install -D -m 644 ${srcdir}/systemd_sysusers.d_storm.conf \
"${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"