summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMeow2015-06-15 20:51:21 +0800
committerMeow2015-06-15 20:51:21 +0800
commit20c5d29b0988134525344b66bfbeeee1ac185ef3 (patch)
tree917609a08383e929e34eab9188573a82bb7b36be
downloadaur-20c5d29b0988134525344b66bfbeeee1ac185ef3.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26be7bb01b88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tweak-hexeditor
+ pkgdesc = Efficient Command Line hex editor
+ pkgver = 3.01
+ pkgrel = 1
+ url = http://www.chiark.greenend.org.uk/~sgtatham/tweak
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = make
+ makedepends = gcc
+ depends = ncurses
+ depends = glibc
+ source = http://mirrors.163.com/debian/pool/main/t/tweak/tweak_3.01.orig.tar.gz
+ md5sums = 3ae8db9fd482b679835a80c4635f71be
+
+pkgname = tweak-hexeditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caa595edc33c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Contributor: Leon Belmont <meow AT linux DOT cn>
+
+pkgname=tweak-hexeditor
+_pkgname=tweak
+pkgdesc="Efficient Command Line hex editor"
+pkgver=3.01
+pkgrel=1
+arch=('i686' 'x86_64')
+depends=('ncurses' 'glibc')
+makedepends=('make' 'gcc')
+url=http://www.chiark.greenend.org.uk/~sgtatham/tweak
+license=('custom')
+source=("http://mirrors.163.com/debian/pool/main/t/tweak/${_pkgname}_${pkgver}.orig.tar.gz")
+md5sums=('3ae8db9fd482b679835a80c4635f71be')
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ sed -ri 's@^(PREFIX=).*$@\1"'${pkgdir}'/usr"@' Makefile
+ make
+}
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make install
+}