summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 09:25:50 -0600
committerMark Wagie2022-04-15 09:25:50 -0600
commit20d22bfac2ccb03ae3853e157bb118288196f8c3 (patch)
tree8e145ae094ada9d988f181ab22339c09e46d3519
parent1eb4790be86916b939d5e429aba87e6c14f616f2 (diff)
downloadaur-20d22bfac2ccb03ae3853e157bb118288196f8c3.tar.gz
standards based build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b91c24556b74..c8a556526551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-block_tracing
pkgdesc = Protect process memory
pkgver = 1.0.1
- pkgrel = 6
+ pkgrel = 7
url = https://thelig.ht/code/block-tracing
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = https://files.pythonhosted.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz
source = https://files.pythonhosted.org/packages/source/b/block_tracing/block_tracing-1.0.1.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index d73be68e4072..acb112a810ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python-block_tracing
_name=${pkgname#python-}
pkgver=1.0.1
-pkgrel=6
+pkgrel=7
pkgdesc="Protect process memory"
arch=('any')
url="https://thelig.ht/code/block-tracing"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"{,.asc}
'LICENSE')
sha256sums=('9faa009a702a8f2f605ebb78314d5ca2a2a93543d061038a3d3a978c93385e68'
@@ -18,12 +18,12 @@ validpgpkeys=('584EDA5AAC13B9FBFB13F678A6A5398DACC9C15C') # Rian Hunter <rian@th
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}