summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Florness2023-06-17 13:11:53 -0400
committerDavid Florness2023-06-17 13:26:24 -0400
commit20eed64712a533dc375b7e98704f4618ab0f2030 (patch)
tree3913bbe20111984e04d42bcaa1f76376c652b77f
parent775de682e729844b33f720e99d6a0bd288131ec1 (diff)
downloadaur-20eed64712a533dc375b7e98704f4618ab0f2030.tar.gz
Upgrade from 0.11.16 to 0.12.0, switch to new build system
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
-rwxr-xr-xupdate.sh16
3 files changed, 37 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96af08192e4c..e035e8286206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,36 @@
pkgbase = sublime-music
pkgdesc = A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.
- pkgver = 0.11.16
- pkgrel = 4
+ pkgver = 0.12.0
+ pkgrel = 1
url = https://sublimemusic.app
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-flit-core
+ makedepends = python-installer
makedepends = python-sphinx
depends = python
depends = python-bleach
+ depends = python-bottle
depends = python-dataclasses-json
depends = python-dateutil
depends = python-deepdiff
- depends = python-fuzzywuzzy
depends = python-gobject
depends = python-levenshtein
depends = python-mpv
depends = python-peewee
+ depends = python-pychromecast
depends = python-requests
depends = python-semver
+ depends = python-thefuzz
optdepends = libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to
optdepends = libnotify: for system song notification support
optdepends = python-keyring: support for storing passwords in the system keyring
optdepends = python-pychromecast: support for casting to Chromecast devices
optdepends = python-bottle: support for casting downloaded files to Chromecasts on the same LAN
- source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime_music-0.11.16.tar.gz
- source = https://gitlab.com/sumner/sublime-music/-/archive/v0.11.16/sublime-music-v0.11.16.tar.gz
- sha256sums = d798fa43b8bb8ebe9a0714927cc185283ae212bf52a9391ebedba8f22fde88e0
- sha256sums = 84165af03c7e9ae3a54801cd5b2903ed26a5fed5b35e4b561b0f8d1f6b2c5832
+ source = https://files.pythonhosted.org/packages/source/s/sublime-music/sublime_music-0.12.0.tar.gz
+ source = https://github.com/sublime-music/sublime-music/archive/refs/tags/v0.12.0.tar.gz
+ sha256sums = 458bacab6be5c926852d4a43ce675b5e767210287844c6fce921832e263db3c0
+ sha256sums = faaf102fd790ecea3d966c9d6e305567c734a1df30eaa6bbdedf93d863bc7435
pkgname = sublime-music
diff --git a/PKGBUILD b/PKGBUILD
index 24b48f1808c2..1b7c3153779b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,25 @@
pkgbase='sublime-music'
pkgname=('sublime-music')
_module='sublime_music'
-pkgver='0.11.16'
-pkgrel=4
+pkgver='0.12.0'
+pkgrel=1
pkgdesc='A native Subsonic/Airsonic/*sonic client for Linux. Built using Python and GTK+.'
url='https://sublimemusic.app'
depends=(
'python'
'python-bleach'
+ 'python-bottle'
'python-dataclasses-json'
'python-dateutil'
'python-deepdiff'
- 'python-fuzzywuzzy'
'python-gobject'
'python-levenshtein'
'python-mpv'
'python-peewee'
+ 'python-pychromecast'
'python-requests'
'python-semver'
+ 'python-thefuzz'
)
optdepends=(
'libnm-glib: for changing the Subsonic server address depending on what SSID you are connected to'
@@ -29,27 +31,29 @@ optdepends=(
'python-bottle: support for casting downloaded files to Chromecasts on the same LAN'
)
makedepends=(
- 'python-setuptools'
+ 'python-build'
+ 'python-flit-core'
+ 'python-installer'
'python-sphinx'
)
license=('GPL3')
arch=('any')
source=(
- 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime_music-0.11.16.tar.gz'
- 'https://gitlab.com/sumner/sublime-music/-/archive/v0.11.16/sublime-music-v0.11.16.tar.gz'
+ 'https://files.pythonhosted.org/packages/source/s/sublime-music/sublime_music-0.12.0.tar.gz'
+ 'https://github.com/sublime-music/sublime-music/archive/refs/tags/v0.12.0.tar.gz'
)
-sha256sums=('d798fa43b8bb8ebe9a0714927cc185283ae212bf52a9391ebedba8f22fde88e0'
- '84165af03c7e9ae3a54801cd5b2903ed26a5fed5b35e4b561b0f8d1f6b2c5832')
+sha256sums=('458bacab6be5c926852d4a43ce675b5e767210287844c6fce921832e263db3c0'
+ 'faaf102fd790ecea3d966c9d6e305567c734a1df30eaa6bbdedf93d863bc7435')
build() {
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
pushd "${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
# Move all of the package data resources to ${pkgdir}/usr/share/sublime-music
data_dir=${pkgdir}/usr/share/sublime-music
@@ -65,7 +69,7 @@ package() {
popd
- pushd "sublime-music-v${pkgver}"
+ pushd "sublime-music-${pkgver}"
desktop-file-install --dir=${pkgdir}/usr/share/applications sublime-music.desktop
install -Dm644 sublime-music.metainfo.xml "${pkgdir}/usr/share/metainfo/sublime-music.metainfo.xml"
diff --git a/update.sh b/update.sh
index 6f08b9f47e9a..ac41f53ff47c 100755
--- a/update.sh
+++ b/update.sh
@@ -7,16 +7,18 @@ DESCRIPTION="A native Subsonic/Airsonic/*sonic client for Linux. Built using Pyt
URL=https://sublimemusic.app
DEPENDS=(
python-bleach
+ python-bottle
python-dataclasses-json
python-dateutil
python-deepdiff
- python-fuzzywuzzy
python-gobject
python-levenshtein
python-mpv
python-peewee
+ python-pychromecast
python-requests
python-semver
+ python-thefuzz
)
LICENSE='GPL3'
ADDITIONAL=
@@ -32,7 +34,7 @@ fi
SRCS=(
https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PKG_NAME}-$1.tar.gz
- https://gitlab.com/sumner/sublime-music/-/archive/v$1/sublime-music-v$1.tar.gz
+ https://github.com/sublime-music/sublime-music/archive/refs/tags/v$1.tar.gz
)
printf '' > PKGBUILD
@@ -62,7 +64,9 @@ optdepends=(
'python-bottle: support for casting downloaded files to Chromecasts on the same LAN'
)
makedepends=(
- 'python-setuptools'
+ 'python-build'
+ 'python-flit-core'
+ 'python-installer'
'python-sphinx'
)
license=('${LICENSE}')
@@ -80,12 +84,12 @@ ${ADDITIONAL}
build() {
cd \"\${srcdir}/\${_module}-\${pkgver}\"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
pushd \"\${_module}-\${pkgver}\"
- python setup.py install --root=\"\${pkgdir}\" --optimize=1 --skip-build
+ python -m installer --destdir=\"\${pkgdir}\" dist/*.whl
# Move all of the package data resources to \${pkgdir}/usr/share/sublime-music
data_dir=\${pkgdir}/usr/share/sublime-music
@@ -101,7 +105,7 @@ package() {
popd
- pushd \"${AUR_NAME}-v\${pkgver}\"
+ pushd \"${AUR_NAME}-\${pkgver}\"
desktop-file-install --dir=\${pkgdir}/usr/share/applications sublime-music.desktop
install -Dm644 sublime-music.metainfo.xml \"\${pkgdir}/usr/share/metainfo/sublime-music.metainfo.xml\"