summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorty2020-12-08 13:09:08 +0100
committerWorty2020-12-08 13:09:08 +0100
commit2102f9ff5b5619c8bc4979ab1c8702ba49297bd5 (patch)
tree6d28a78071c4e0228408becb45715cf0afd77a13
parentc1062da2dc405aa8755912dba70e65c6fad7927e (diff)
downloadaur-2102f9ff5b5619c8bc4979ab1c8702ba49297bd5.tar.gz
v1.25.3 | New maintainer
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--silence-dlerror.patch17
3 files changed, 13 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11bb8715a15e..a44db72b3f7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fakeroot-tcp
pkgdesc = Tool for simulating superuser privileges,with tcp ipc
- pkgver = 1.24
- pkgrel = 2
+ pkgver = 1.25.3
+ pkgrel = 1
url = http://packages.debian.org/fakeroot
install = fakeroot.install
arch = i686
@@ -11,17 +11,16 @@ pkgbase = fakeroot-tcp
license = GPL
makedepends = po4a
makedepends = automake
+ makedepends = autoconf
depends = glibc
depends = filesystem
depends = sed
depends = util-linux
depends = sh
- provides = fakeroot=1.24-2
+ provides = fakeroot=1.25.3-1
conflicts = fakeroot
- source = http://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_1.24.orig.tar.gz
- source = silence-dlerror.patch
- md5sums = 964e5f438f1951e5a515dd54edd50fa6
- md5sums = 5fba0b541b5af39d804265223fda525c
+ source = http://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_1.25.3.orig.tar.gz
+ md5sums = f6104ef6960c962377ef062bf222a1d2
pkgname = fakeroot-tcp
diff --git a/PKGBUILD b/PKGBUILD
index 549a8a37bb41..0cc0fa9b7b61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,24 @@
-# Maintainer: 4679 <admin@libnull.com>
+# Maintainer: w0rty <mawo97 at gmail.com>
+# Contributor: 4679 <admin@libnull.com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Jochem Kossen <j.kossen@home.nl>
pkgname=fakeroot-tcp
_pkgname=fakeroot
-pkgver=1.24
-pkgrel=2
+pkgver=1.25.3
+pkgrel=1
pkgdesc='Tool for simulating superuser privileges,with tcp ipc'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('GPL')
url="http://packages.debian.org/fakeroot"
install=fakeroot.install
depends=('glibc' 'filesystem' 'sed' 'util-linux' 'sh')
-makedepends=('po4a' 'automake')
+makedepends=('po4a' 'automake' 'autoconf')
provides=("${_pkgname}=${pkgver}-${pkgrel}")
conflicts=("${_pkgname}")
-source=(http://ftp.debian.org/debian/pool/main/f/$_pkgname/${_pkgname}_${pkgver}.orig.tar.gz
- silence-dlerror.patch)
-md5sums=('964e5f438f1951e5a515dd54edd50fa6'
- '5fba0b541b5af39d804265223fda525c')
-
-prepare() {
- cd $_pkgname-$pkgver
- patch -p1 -i "$srcdir"/silence-dlerror.patch
-}
+source=(http://ftp.debian.org/debian/pool/main/f/$_pkgname/${_pkgname}_${pkgver}.orig.tar.gz)
+md5sums=('f6104ef6960c962377ef062bf222a1d2')
build() {
cd $_pkgname-$pkgver
diff --git a/silence-dlerror.patch b/silence-dlerror.patch
deleted file mode 100644
index a4472d8f7c7b..000000000000
--- a/silence-dlerror.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/libfakeroot.c b/libfakeroot.c
-index f867758..7ef6e47 100644
---- a/libfakeroot.c
-+++ b/libfakeroot.c
-@@ -256,10 +256,12 @@ void load_library_symbols(void){
- /* clear dlerror() just in case dlsym() legitimately returns NULL */
- msg = dlerror();
- *(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
-+#ifdef LIBFAKEROOT_DEBUGGING
- if ( (msg = dlerror()) != NULL){
- fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
- /* abort ();*/
- }
-+#endif /* LIBFAKEROOT_DEBUGGING */
- }
- }
-