summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2021-07-02 14:29:05 +0200
committerSibren Vasse2021-07-02 14:29:41 +0200
commit2124d34d76463ebea1059907115d06681aa49cce (patch)
tree61f5ee4e0bb8890e1b332cc6eb3cb40d0bebfd00
parent9dca6ea920b577034bd593ea558b68572353507d (diff)
downloadaur-2124d34d76463ebea1059907115d06681aa49cce.tar.gz
v5.30.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--menu-bar.patch13
-rw-r--r--quit.patch33
-rw-r--r--systray.patch12
5 files changed, 20 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f93052e2690a..fe681029a77b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deezer
pkgdesc = A proprietary music streaming service
- pkgver = 5.20.0
+ pkgver = 5.30.0
pkgrel = 1
url = https://www.deezer.com/
arch = any
@@ -13,17 +13,13 @@ pkgbase = deezer
makedepends = nodejs
depends = electron
provides = deezer
- source = deezer-5.20.0-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/5.20.0
+ source = deezer-5.30.0-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/5.30.0
source = deezer.desktop
source = deezer
- source = systray.patch
- source = menu-bar.patch
source = quit.patch
- sha256sums = 67f9b5bc55703b6bb1e1f0420c3b2c7f6a398bb0e6057e0b9e67a148f97ffbdc
+ sha256sums = 1c00d286f209de69ff5fee811a5662b8d7114046a9c74348c31ce955352b5856
sha256sums = f8a5279239b56082a5c85487b0c261fb332623f27dac3ec8093458b8c55d8d99
sha256sums = 8717ba2de9cabc5c0a35780315871329c15bde5ff46c4f0bf859a87e42aa96f5
- sha256sums = 82fa9d6dbfea95dec625675fa6af0bbaa95b1d41b68728302260373a2d659b3f
- sha256sums = 191c139553332e624463a31ef6cb435bcd83ab343c6cdc5bcab3152386c0a3e6
- sha256sums = a3476917a031dc2b989b12008e6ecf564acf9fcfe6cfde4eb4f912711da74662
+ sha256sums = d3f96ae6019abb60aa097919b22b1873f83061ed7453cd251e43b3afe5d54919
pkgname = deezer
diff --git a/PKGBUILD b/PKGBUILD
index 76ca7fb46514..53a5aa641b2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
# Contributor: Ilya Gulya <ilyagulya@gmail.com>
pkgname="deezer"
-pkgver=5.20.0
+pkgver=5.30.0
pkgrel=1
pkgdesc="A proprietary music streaming service"
arch=('any')
@@ -13,15 +13,11 @@ makedepends=('p7zip' 'asar' 'prettier' 'imagemagick' 'npm' 'nodejs')
source=("$pkgname-$pkgver-setup.exe::https://www.deezer.com/desktop/download/artifact/win32/x86/$pkgver"
"$pkgname.desktop"
deezer
- systray.patch
- menu-bar.patch
quit.patch)
-sha256sums=('67f9b5bc55703b6bb1e1f0420c3b2c7f6a398bb0e6057e0b9e67a148f97ffbdc'
+sha256sums=('1c00d286f209de69ff5fee811a5662b8d7114046a9c74348c31ce955352b5856'
'f8a5279239b56082a5c85487b0c261fb332623f27dac3ec8093458b8c55d8d99'
'8717ba2de9cabc5c0a35780315871329c15bde5ff46c4f0bf859a87e42aa96f5'
- '82fa9d6dbfea95dec625675fa6af0bbaa95b1d41b68728302260373a2d659b3f'
- '191c139553332e624463a31ef6cb435bcd83ab343c6cdc5bcab3152386c0a3e6'
- 'a3476917a031dc2b989b12008e6ecf564acf9fcfe6cfde4eb4f912711da74662')
+ 'd3f96ae6019abb60aa097919b22b1873f83061ed7453cd251e43b3afe5d54919')
prepare() {
# Extract app from installer
@@ -36,11 +32,10 @@ prepare() {
asar extract app.asar app
cd "$srcdir/resources/app"
+ mkdir -p resources/linux/
+ install -Dm644 "$srcdir/resources/win/systray.png" resources/linux/
+
prettier --write "build/*.js"
- # Ugly systray icon fix
- patch -p1 <"$srcdir/systray.patch"
- # Disable menu bar
- patch -p1 <"$srcdir/menu-bar.patch"
# Hide to tray (https://github.com/SibrenVasse/deezer/issues/4)
patch -p1 <"$srcdir/quit.patch"
diff --git a/menu-bar.patch b/menu-bar.patch
deleted file mode 100644
index 702156bfc738..000000000000
--- a/menu-bar.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/build/main.js b/build/main.js
-index ff2a38b..823a767 100644
---- a/build/main.js
-+++ b/build/main.js
-@@ -3062,6 +3062,8 @@
- mainView.setAutoResize({ width: !0, height: !0 });
- } else this.appService.setWindow(this.window, void 0);
- this.appService.setUserAgent(),
-+ this.window.setAutoHideMenuBar(true),
-+ this.window.setMenuBarVisibility(false),
- isPlatform(PLATFORM.DARWIN)
- ? this.window.on("moved", () => {
- this.windowState.save();
diff --git a/quit.patch b/quit.patch
index 3f53ce7cb53a..31fb2432b86c 100644
--- a/quit.patch
+++ b/quit.patch
@@ -1,26 +1,13 @@
diff --git a/build/main.js b/build/main.js
-index 823a767..3e67094 100644
+index 5066eef..46b04c5 100644
--- a/build/main.js
+++ b/build/main.js
-@@ -1650,7 +1650,7 @@
- };
- }
- getQuitOptions() {
-- return { label: i18n_t("menu_quit-deezer_label"), role: "quit" };
-+ return { label: i18n_t("menu_quit-deezer_label"), click: () => { external_electron_namespaceObject.app.isQuiting = true; external_electron_namespaceObject.app.quit(); } };
- }
- getReloadOptions() {
- return {
-@@ -3075,6 +3075,12 @@
- this.isFrameless && this._adjustViewToContentSize(),
- this.windowState.save();
- }),
-+ this.window.on('close', function(event) {
-+ if(!external_electron_namespaceObject.app.isQuiting){
-+ event.preventDefault();
-+ this.hide();
-+ }
-+ }),
- this.window.once("ready-to-show", () => {
- if (windowState.isMaximized) this.window.maximize();
- else if (isPlatform(PLATFORM.WINDOWS)) {
+@@ -3079,7 +3080,7 @@
+ this._adjustViewToContentSize(),
+ mainView.setAutoResize({ width: !0, height: !0 });
+ } else this.appService.setWindow(this.window, void 0);
+- if ((this.appService.setUserAgent(), isPlatform(PLATFORM.DARWIN))) {
++ if ((this.appService.setUserAgent(), isPlatform(PLATFORM.LINUX))) {
+ let isQuitting = !1;
+ external_electron_namespaceObject.app.on(
+ "before-quit",
diff --git a/systray.patch b/systray.patch
deleted file mode 100644
index 3fef02a4ee3c..000000000000
--- a/systray.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/build/main.js b/build/main.js
-index 18ff27d..ff2a38b 100644
---- a/build/main.js
-+++ b/build/main.js
-@@ -104,6 +104,7 @@
- : PLATFORM.UNKNOWN;
- }
- function getAppIcon() {
-+ return "/usr/share/deezer/systray.png";
- let appIcon = "";
- switch (getPlatformName()) {
- case PLATFORM.WINDOWS: