summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-04 15:53:47 +0100
committerXZS2016-11-04 15:55:07 +0100
commit2154fd9120937fd2bd1cd071d1c02c147aea05fc (patch)
treede7fa65cbd95f9e27fc2fe17f3e6f2bd672df380
parentbc0d37e1b2236c8907bbbcd1e0384156fa16df35 (diff)
downloadaur-2154fd9120937fd2bd1cd071d1c02c147aea05fc.tar.gz
use time stamp from meta data
The meta data contains an upload time stamp. It is much easier to use than finding the latest date from all the files.
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 678f0065fd96..bec57e2274c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: FadeMind <fademind@gmail.com>
pkgname=aurora-themes
-pkgver=3.20.20160705
+pkgver=3.20.20160929
pkgrel=1
pkgdesc='Easy On The Eyes GNOME Shell, GTK2, GTK3 and Cinnamon themes'
arch=('any')
@@ -39,14 +39,7 @@ prepare() {
pkgver() {
meta version
- while read -rd $'\0'
- do
- if [[ "$REPLY" -gt "$max" ]]
- then
- max="$REPLY"
- fi
- done < <(find */ -type f -exec stat --printf="%Y\0" '{}' +)
- date -d "@$max" +.%Y%m%d
+ date -d "$(meta updated_timestamp)" +.%Y%m%d
}
package() {