summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-14 01:03:12 +0800
committerChocobo12017-08-14 01:50:53 +0800
commit21555a98cbd4c49365e5778288a6f92914c96fce (patch)
tree1875b96794be25f8eec00761628ff1e173cad45c
downloadaur-21555a98cbd4c49365e5778288a6f92914c96fce.tar.gz
newpkg: bison-git 3.0.4.r16.gd6445ec1-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22784bb13abb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bison-git
+ pkgdesc = The GNU general-purpose parser generator
+ pkgver = 3.0.4.r16.gd6445ec1
+ pkgrel = 1
+ url = https://www.gnu.org/software/bison/bison.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gzip
+ makedepends = rsync
+ makedepends = tar
+ depends = glibc
+ provides = bison
+ conflicts = bison
+ source = git+https://git.savannah.gnu.org/git/bison.git
+ sha256sums = SKIP
+
+pkgname = bison-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e915d1b7e68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=bison-git
+pkgver=3.0.4.r16.gd6445ec1
+pkgrel=1
+pkgdesc="The GNU general-purpose parser generator"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/bison/bison.html"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git' 'gzip' 'rsync' 'tar')
+provides=('bison')
+conflicts=('bison')
+source=("git+https://git.savannah.gnu.org/git/bison.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "bison"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "bison"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "bison"
+
+ make check
+}
+
+package() {
+ cd "bison"
+
+ make DESTDIR="$pkgdir" install
+}