summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph332015-06-23 13:19:41 +0200
committerZeph332015-06-23 13:19:41 +0200
commit2161be8daf349c61349a7ee6cd5a98b5bf433bea (patch)
tree2c06b8fea0fac06f2997a92a5b67c0846de7cf7e
downloadaur-2161be8daf349c61349a7ee6cd5a98b5bf433bea.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
-rw-r--r--rabbitvcs-nautilus.install29
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc9617a652f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rabbitvcs-nautilus
+ pkgdesc = Nautilus front-end for RabbitVCS
+ pkgver = 0.16
+ pkgrel = 1
+ url = http://rabbitvcs.org/
+ install = rabbitvcs-nautilus.install
+ arch = any
+ license = GPL
+ depends = nautilus>=3.0.0
+ depends = python2-nautilus
+ depends = python2-dbus
+ depends = rabbitvcs>=0.16
+ source = https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz
+ md5sums = 25376cff136ad2fac901ff88e07893ef
+
+pkgname = rabbitvcs-nautilus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45fdda29bc48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Zeph <zeph33@gmail.com>
+# Maintainer: Zeph <zeph33@gmail.com>
+
+pkgname=rabbitvcs-nautilus
+pkgver=0.16
+pkgrel=1
+pkgdesc="Nautilus front-end for RabbitVCS"
+arch=('any')
+url="http://rabbitvcs.org/"
+install=$pkgname.install
+depends=('nautilus>=3.0.0' 'python2-nautilus' 'python2-dbus' "rabbitvcs>=$pkgver")
+license=('GPL')
+source=("https://github.com/rabbitvcs/rabbitvcs/archive/v0.16.tar.gz")
+md5sums=('25376cff136ad2fac901ff88e07893ef')
+
+package(){
+ install -D "$srcdir/rabbitvcs-$pkgver/clients/nautilus-3.0/RabbitVCS.py" "$pkgdir/usr/share/nautilus-python/extensions/RabbitVCS.py"
+}
diff --git a/rabbitvcs-nautilus.install b/rabbitvcs-nautilus.install
new file mode 100644
index 000000000000..3e6912a3c677
--- /dev/null
+++ b/rabbitvcs-nautilus.install
@@ -0,0 +1,29 @@
+post_install(){
+cat << _EOF
+=> Be sure to restart Nautilus for RabbitCVS to get loaded.
+=> Restart nautilus with the following commands:
+=> $ nautilus -q
+=> $ pgrep -f service.py | xargs kill
+=> $ nohup nautilus > /dev/null &
+_EOF
+}
+
+post_upgrade(){
+cat << _EOF
+=> Be sure to restart Nautilus for RabbitCVS to get reloaded.
+=> Restart nautilus with the following commands:
+=> $ pgrep -f service.py | xargs kill
+=> $ nautilus -q
+=> $ nohup nautilus > /dev/null &
+_EOF
+}
+
+post_remove(){
+cat << _EOF
+=> Be sure to restart Nautilus for RabbitCVS to get unloaded.
+=> Restart nautilus with the following commands:
+=> $ pgrep -f service.py | xargs kill
+=> $ nautilus -q
+=> $ nohup nautilus > /dev/null &
+_EOF
+}