summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:19:21 +0200
committerMoritz Lipp2015-06-15 20:19:21 +0200
commit217ef7a6884735b63e8162fa8bd73fd13ab2b2b5 (patch)
tree4b58809c43aecbf1eb504700c763d7bd2f849fa1
downloadaur-217ef7a6884735b63e8162fa8bd73fd13ab2b2b5.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
-rw-r--r--smartscope.sh3
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58b2b89a45d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = smartscope
+ pkgdesc = SmartScope App
+ pkgver = 0.0.8.3
+ pkgrel = 1
+ url = https://www.lab-nation.com/
+ arch = x86_64
+ arch = i686
+ license = unknown
+ makedepends = tar
+ depends = mono
+ depends = sdl_mixer
+ depends = libusb
+ source = SmartScope-Linux-0-0-8-3.deb::https://www.lab-nation.com/package/smartscope/linux/latest/get
+ source = smartscope.sh
+ md5sums = 6327d62a18fb03dae7866a75ce7d5a28
+ md5sums = 4e63224a3a40e165cf4bd2f777d288dc
+
+pkgname = smartscope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa608280fca2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Moritz Lipp <mail@mlq.me>
+pkgname=smartscope
+pkgver=0.0.8.3
+pkgrel=1
+pkgdesc="SmartScope App"
+arch=('x86_64' 'i686')
+url="https://www.lab-nation.com/"
+license=('unknown')
+depends=('mono' 'sdl_mixer' 'libusb')
+makedepends=('tar')
+
+_pkgver=`echo $pkgver | sed 's/\./-/g'`
+_pkgname=SmartScope-Linux
+
+source=("$_pkgname-$_pkgver.deb::https://www.lab-nation.com/package/smartscope/linux/latest/get"
+"smartscope.sh")
+md5sums=('6327d62a18fb03dae7866a75ce7d5a28'
+ '4e63224a3a40e165cf4bd2f777d288dc')
+
+package() {
+ cd "$srcdir"
+ tar xfv data.tar.xz -C $pkgdir
+ install -D -m755 smartscope.sh "$pkgdir/usr/bin/smartscope"
+}
diff --git a/smartscope.sh b/smartscope.sh
new file mode 100644
index 000000000000..f40b0a0035e6
--- /dev/null
+++ b/smartscope.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+mono /opt/smartscope/SmartScope.exe