summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:46:33 +0000
committerJoão Figueiredo2023-02-13 00:46:33 +0000
commit2189429a350edd2966d0182032be9e6df9b10a8f (patch)
tree8e2012cd807072781659b40aebcbcb033e042fa5
parentc86e2bb20cab2448c2ca5297476cfd466c9ce4d7 (diff)
downloadaur-2189429a350edd2966d0182032be9e6df9b10a8f.tar.gz
Migrate to Qt6 (this time for real!)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93fbeeafbc16..901caa76c52a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,18 +4,18 @@ pkgbase = knotifications-git
pkgrel = 1
url = https://community.kde.org/Frameworks
arch = x86_64
- groups = kf5-git
+ groups = kf6-git
license = LGPL
makedepends = git
makedepends = extra-cmake-modules-git
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = doxygen
depends = libcanberra
- depends = libdbusmenu-qt5
+ depends = libdbusmenu-qt6
depends = kwindowsystem-git
depends = kconfig-git
depends = kcoreaddons-git
- depends = qt5-speech
+ depends = qt6-speech
depends = libxtst
provides = knotifications
conflicts = knotifications
diff --git a/PKGBUILD b/PKGBUILD
index 218525ef551d..ca6001348fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ pkgdesc='Abstraction for system notifications'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(libcanberra libdbusmenu-qt5 kwindowsystem-git kconfig-git kcoreaddons-git qt5-speech libxtst)
-makedepends=(git extra-cmake-modules-git qt5-tools doxygen)
+depends=(libcanberra libdbusmenu-qt6 kwindowsystem-git kconfig-git kcoreaddons-git qt6-speech libxtst)
+makedepends=(git extra-cmake-modules-git qt6-tools doxygen)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}