summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiklas2017-10-26 01:09:10 +0200
committerNiklas2017-10-26 01:09:10 +0200
commit21aa953e383a4547769329c29cc6ddd0cd95b0a0 (patch)
tree90ce974b812dbf4a4a587fe00f3e0ad86051893d
downloadaur-21aa953e383a4547769329c29cc6ddd0cd95b0a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
-rw-r--r--homegear-insteon.install10
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bee21b840613
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = homegear-insteon
+ pkgdesc = Insteon module for Homegear
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = https://homegear.eu
+ install = homegear-insteon.install
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = homegear
+ backup = etc/homegear/families/insteon.conf
+ source = https://github.com/Homegear/Homegear-Insteon/archive/0.7.10.tar.gz
+ sha512sums = ae54c49f2d06cdaacb27366eef507a64d7b1334a7943c5515f1f6fad951a6702ccd59451c44664ae69568f9de45c72ff85e068fac24cad38cf2f8bb64513fd13
+
+pkgname = homegear-insteon
+ backup = etc/homegear/families/insteon.conf
+ backup = etc/homegear/devices/2/
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..afcd2f9b7f58
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..802cacf1c2c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Niklas <dev@n1klas.net>
+
+pkgname='homegear-insteon'
+_gitname='Homegear-Insteon'
+pkgdesc='Insteon module for Homegear'
+pkgver=0.7.10
+pkgrel=1
+arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
+license=('GPL3')
+url="https://homegear.eu"
+depends=('homegear')
+source=("https://github.com/Homegear/${_gitname}/archive/${pkgver}.tar.gz")
+sha512sums=('ae54c49f2d06cdaacb27366eef507a64d7b1334a7943c5515f1f6fad951a6702ccd59451c44664ae69568f9de45c72ff85e068fac24cad38cf2f8bb64513fd13')
+install=homegear-insteon.install
+backup=('etc/homegear/families/insteon.conf')
+
+prepare() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+
+ # Use the our version number instead of the script which would have fetched it from Github
+ sed -i -e "s#m4_esyscmd_s(\[./getVersion.sh\])#${pkgver}#" configure.ac
+ # Put the modules in /usr/lib instead of /var/lib because that is where they belong
+ sed -i -e 's#libdir = $(localstatedir)/lib/homegear/modules#libdir = $(prefix)/lib/homegear/modules#' src/Makefile.am
+}
+
+build() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+
+ ./bootstrap
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 misc/Config\ Directory/insteon.conf "${pkgdir}"/etc/homegear/families/insteon.conf
+ install -dm755 "${pkgdir}"/etc/homegear/devices/2
+ cp -r misc/Device\ Description\ Files/* "${pkgdir}"/etc/homegear/devices/2
+ chmod 644 "${pkgdir}"/etc/homegear/devices/2/*
+
+ cd "${pkgdir}"/etc/homegear/devices/2
+ for filename in *.xml
+ do
+ backup+=("etc/homegear/devices/2/${filename}")
+ done
+}
diff --git a/homegear-insteon.install b/homegear-insteon.install
new file mode 100644
index 000000000000..1710ec5980e1
--- /dev/null
+++ b/homegear-insteon.install
@@ -0,0 +1,10 @@
+post_install() {
+ if [ "`systemctl is-active homegear`" == "active" ]
+ then
+ homegear -e mld mod_insteon.so
+ fi
+}
+
+post_upgrade() {
+ post_install
+}