summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHikari Hayashi2022-11-05 16:28:12 +0800
committerHikari Hayashi2022-11-05 16:29:10 +0800
commit21d57552883129850d898295dac334b86ac34284 (patch)
tree1ad8b31f97fa01968ea7e7e210798fb46fce7617
parent5d6757ea2c4ae18f497db26dc83d924f26ff1b56 (diff)
downloadaur-21d57552883129850d898295dac334b86ac34284.tar.gz
6.1-rc3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch32
-rw-r--r--ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch39
-rw-r--r--PKGBUILD16
-rw-r--r--config6
-rw-r--r--patch-realtek-um5302ta-quirk.patch12
7 files changed, 51 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c5ba90e0386..6d6635329493 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = linux-mainline-um5302ta
pkgdesc = Linux
- pkgver = 6.0
- pkgrel = 2
- url = https://git.kernel.org/torvalds/h/v6.0
+ pkgver = 6.1rc3
+ pkgrel = 1
+ url = https://git.kernel.org/torvalds/h/v6.1-rc3
arch = x86_64
license = GPL2
makedepends = bc
@@ -20,19 +20,17 @@ pkgbase = linux-mainline-um5302ta
makedepends = texlive-latexextra
makedepends = git
options = !strip
- source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.0
+ source = linux-mainline::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=v6.1-rc3
source = config
+ source = ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch
source = cs35l42-hda-no-acpi-dsd-csc3551.patch
- source = patch-realtek-um5302ta-quirk.patch
- source = ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
- sha256sums = 6ed43ed093ec7dcbbac286edc204873edfa77e380ac43c8cc2f40b2965ac1aa3
+ sha256sums = 05168cbbeb6378eec6c84fe3300cede4fa5cf6130c39fb8af95040529bd390a6
+ sha256sums = 1391b24a25148c3f1a60867d2f805f85c3dd201ffd0293b66d1ac892da20d910
sha256sums = 405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82
- sha256sums = 9bb8bba7e33aa57b54f855d9dd788e9aa63e8c01526454694438cbaa22b1b7c5
- sha256sums = c5e4e17c3e265710325d2af16bb1ba3b4a6e22f10677fef79ce7a22f91596bda
pkgname = linux-mainline-um5302ta
pkgdesc = The Linux kernel and modules
diff --git a/.gitignore b/.gitignore
index 411fe5757a11..77323655c090 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,6 +3,5 @@
!/PKGBUILD
!/.SRCINFO
!/config
+!/ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch
!/cs35l42-hda-no-acpi-dsd-csc3551.patch
-!/patch-realtek-um5302ta-quirk.patch
-!/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
diff --git a/ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch b/ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch
new file mode 100644
index 000000000000..82ca9976ea95
--- /dev/null
+++ b/ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch
@@ -0,0 +1,32 @@
+From 8d06679b25fc6813eb2438fac7fa13f4f3c2ef37 Mon Sep 17 00:00:00 2001
+From: Stefan Binding <sbinding@opensource.cirrus.com>
+Date: Fri, 28 Oct 2022 11:27:42 +0100
+Subject: ALSA: hda/realtek: Add quirk for ASUS Zenbook using CS35L41
+
+This Asus Zenbook laptop use Realtek HDA codec combined with
+2xCS35L41 Amplifiers using I2C with Internal Boost.
+
+Signed-off-by: Stefan Binding <sbinding@opensource.cirrus.com>
+Cc: <stable@vger.kernel.org>
+Link: https://lore.kernel.org/r/20221028102742.2588687-1-sbinding@opensource.cirrus.com
+Signed-off-by: Takashi Iwai <tiwai@suse.de>
+---
+ sound/pci/hda/patch_realtek.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+(limited to 'sound/pci/hda/patch_realtek.c')
+
+diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
+index 701a72ec5629a..b4f7ff8cfe41b 100644
+--- a/sound/pci/hda/patch_realtek.c
++++ b/sound/pci/hda/patch_realtek.c
+@@ -9404,6 +9404,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
+ SND_PCI_QUIRK(0x1043, 0x1e8e, "ASUS Zephyrus G15", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x1c52, "ASUS Zephyrus G15 2022", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x1f11, "ASUS Zephyrus G14", ALC289_FIXUP_ASUS_GA401),
++ SND_PCI_QUIRK(0x1043, 0x1f12, "ASUS UM5302", ALC287_FIXUP_CS35L41_I2C_2),
+ SND_PCI_QUIRK(0x1043, 0x1f92, "ASUS ROG Flow X16", ALC289_FIXUP_ASUS_GA401),
+ SND_PCI_QUIRK(0x1043, 0x3030, "ASUS ZN270IE", ALC256_FIXUP_ASUS_AIO_GPIO2),
+ SND_PCI_QUIRK(0x1043, 0x831a, "ASUS P901", ALC269_FIXUP_STEREO_DMIC),
+--
+cgit
diff --git a/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch b/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
deleted file mode 100644
index 0edafd25276f..000000000000
--- a/ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 4df5b13dec9e1b5a12db47ee92eb3f7da5c3deb5 Mon Sep 17 00:00:00 2001
-From: Xiaoyan Li <lxy.lixiaoyan@gmail.com>
-Date: Tue, 20 Sep 2022 15:14:34 -0500
-Subject: ASoC: amd: yc: Add ASUS UM5302TA into DMI table
-
-ASUS Zenbook S 13 OLED (UM5302TA) needs this quirk to get the built-in
-microphone working properly.
-
-Link: https://bugzilla.kernel.org/show_bug.cgi?id=216270
-Signed-off-by: Xiaoyan Li <lxy.lixiaoyan@gmail.com>
-Suggested-by: Mario Limonciello <mario.limonciello@amd.com>
-Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>
-Signed-off-by: Mario Limonciello <mario.limonciello@amd.com>
-Link: https://lore.kernel.org/r/20220920201436.19734-2-mario.limonciello@amd.com
-Signed-off-by: Mark Brown <broonie@kernel.org>
----
- sound/soc/amd/yc/acp6x-mach.c | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/sound/soc/amd/yc/acp6x-mach.c b/sound/soc/amd/yc/acp6x-mach.c
-index e0b24e1daef3d..5eab3baf3573d 100644
---- a/sound/soc/amd/yc/acp6x-mach.c
-+++ b/sound/soc/amd/yc/acp6x-mach.c
-@@ -171,6 +171,13 @@ static const struct dmi_system_id yc_acp_quirk_table[] = {
- DMI_MATCH(DMI_PRODUCT_NAME, "21J6"),
- }
- },
-+ {
-+ .driver_data = &acp6x_card,
-+ .matches = {
-+ DMI_MATCH(DMI_BOARD_VENDOR, "ASUSTeK COMPUTER INC."),
-+ DMI_MATCH(DMI_PRODUCT_NAME, "UM5302TA"),
-+ }
-+ },
- {}
- };
-
---
-cgit
diff --git a/PKGBUILD b/PKGBUILD
index 0c3c12a40efe..d75a279ed3a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-mainline-um5302ta
-pkgver=6.0
-pkgrel=2
+pkgver=6.1rc3
+pkgrel=1
pkgdesc='Linux'
-_srctag=v6.0
+_srctag=v6.1-rc3
url="https://git.kernel.org/torvalds/h/$_srctag"
arch=(x86_64)
license=(GPL2)
@@ -19,9 +19,8 @@ _srcname=linux-mainline
source=(
"$_srcname::git+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git#tag=$_srctag"
config # the main kernel config file
+ ALSA-hda-realtek-Add-quirk-for-ASUS-Zenbook-using-CS35L41.patch
cs35l42-hda-no-acpi-dsd-csc3551.patch
- patch-realtek-um5302ta-quirk.patch
- ASoC-amd-yc-Add-ASUS-UM5302TA-into-DMI-table.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -29,10 +28,9 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '6ed43ed093ec7dcbbac286edc204873edfa77e380ac43c8cc2f40b2965ac1aa3'
- '405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82'
- '9bb8bba7e33aa57b54f855d9dd788e9aa63e8c01526454694438cbaa22b1b7c5'
- 'c5e4e17c3e265710325d2af16bb1ba3b4a6e22f10677fef79ce7a22f91596bda')
+ '05168cbbeb6378eec6c84fe3300cede4fa5cf6130c39fb8af95040529bd390a6'
+ '1391b24a25148c3f1a60867d2f805f85c3dd201ffd0293b66d1ac892da20d910'
+ '405100dba08840def4e9546f6e49616cc6bb3d9d25d26c58fa32cd82b4d3df82')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/config b/config
index ddb92e803769..ffc1c82956a6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.0.1-arch2 Kernel Configuration
+# Linux/x86 6.0.5-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.2.0"
CONFIG_CC_IS_GCC=y
@@ -17,7 +17,7 @@ CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_CC_HAS_ASM_INLINE=y
CONFIG_CC_HAS_NO_PROFILE_FN_ATTR=y
-CONFIG_PAHOLE_VERSION=123
+CONFIG_PAHOLE_VERSION=124
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_TABLE_SORT=y
CONFIG_THREAD_INFO_IN_TASK=y
@@ -7596,6 +7596,7 @@ CONFIG_HID_SMARTJOYPLUS=m
CONFIG_SMARTJOYPLUS_FF=y
CONFIG_HID_TIVO=m
CONFIG_HID_TOPSEED=m
+CONFIG_HID_TOPRE=m
CONFIG_HID_THINGM=m
CONFIG_HID_THRUSTMASTER=m
CONFIG_THRUSTMASTER_FF=y
@@ -10850,6 +10851,7 @@ CONFIG_DEBUG_KERNEL=y
# Compile-time checks and compiler options
#
CONFIG_DEBUG_INFO=y
+CONFIG_AS_HAS_NON_CONST_LEB128=y
# CONFIG_DEBUG_INFO_NONE is not set
# CONFIG_DEBUG_INFO_DWARF_TOOLCHAIN_DEFAULT is not set
# CONFIG_DEBUG_INFO_DWARF4 is not set
diff --git a/patch-realtek-um5302ta-quirk.patch b/patch-realtek-um5302ta-quirk.patch
deleted file mode 100644
index 617265348484..000000000000
--- a/patch-realtek-um5302ta-quirk.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
-index f9d46ae4c7b7..1774a6d981a8 100644
---- a/sound/pci/hda/patch_realtek.c
-+++ b/sound/pci/hda/patch_realtek.c
-@@ -9392,6 +9392,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
- SND_PCI_QUIRK(0x1043, 0x1e8e, "ASUS Zephyrus G15", ALC289_FIXUP_ASUS_GA401),
- SND_PCI_QUIRK(0x1043, 0x1c52, "ASUS Zephyrus G15 2022", ALC289_FIXUP_ASUS_GA401),
- SND_PCI_QUIRK(0x1043, 0x1f11, "ASUS Zephyrus G14", ALC289_FIXUP_ASUS_GA401),
-+ SND_PCI_QUIRK(0x1043, 0x1f12, "ASUS UM5302TA", ALC287_FIXUP_CS35L41_I2C_2),
- SND_PCI_QUIRK(0x1043, 0x3030, "ASUS ZN270IE", ALC256_FIXUP_ASUS_AIO_GPIO2),
- SND_PCI_QUIRK(0x1043, 0x831a, "ASUS P901", ALC269_FIXUP_STEREO_DMIC),
- SND_PCI_QUIRK(0x1043, 0x834a, "ASUS S101", ALC269_FIXUP_STEREO_DMIC),