summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2019-01-13 21:06:13 -0500
committerEli Schwartz2019-01-13 23:15:14 -0500
commit21db80131c12c974f71ef72930d8e633b327722b (patch)
tree41c0263c2c3f16cf7194cdc2be86325d68d2a9c9
parent3655a0e348935fd34c67472e1a10b99ac21d561d (diff)
downloadaur-21db80131c12c974f71ef72930d8e633b327722b.tar.gz
upgpkg: pacman-git 5.1.1.r115.g10bcf66d-1
update optdepends and makepkg.conf to match core/pacman
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--makepkg.conf4
3 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d540cd051f6a..3bb892ec1bf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacman-git
pkgdesc = A library-based package manager with dependency support
- pkgver = 5.1.1.r75.g5fc3056e
+ pkgver = 5.1.1.r115.g10bcf66d
pkgrel = 1
url = https://www.archlinux.org/pacman/
arch = i686
@@ -22,6 +22,7 @@ pkgbase = pacman-git
depends = libarchive
depends = pacman-mirrorlist
optdepends = pacman-contrib: various helper utilities
+ optdepends = xdelta3: delta support in repo-add
provides = pacman=5.1.1
conflicts = pacman
options = emptydirs
@@ -38,7 +39,7 @@ pkgbase = pacman-git
sha256sums = 0c087d26e80333267391a6e9e34b95a2ffb103cb9391cb53cc5d97ad954af774
sha256sums = c5a3ec55f9d1bc52e5e5b127f76b7b16b79738268691a3e1d842359033e460da
sha256sums = 2d17478fd607c75e396fe10ef2add8bc9fcc12054810fb6f4409dfb70e01989e
- sha256sums = 2d66473febac0e142eb5b5b2b2c6341687b1afaa89c76ca4e6803499b60636f1
+ sha256sums = 3159b78d6112f4e8906945d1adc1f33b6186d566b54a5976e3a684597c082942
pkgname = pacman-git
diff --git a/PKGBUILD b/PKGBUILD
index 0aab18d05035..46f98536c017 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=5.1.1.r75.g5fc3056e
+pkgver=5.1.1.r115.g10bcf66d
pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -13,7 +13,8 @@ url="https://www.archlinux.org/pacman/"
license=('GPL')
depends=('archlinux-keyring' 'bash' 'curl' 'gpgme' 'libarchive'
'pacman-mirrorlist')
-optdepends=('pacman-contrib: various helper utilities')
+optdepends=('pacman-contrib: various helper utilities'
+ 'xdelta3: delta support in repo-add')
makedepends=('git' 'asciidoc' 'meson')
checkdepends=('python' 'fakechroot')
provides=("pacman=${pkgver%.*.*}")
@@ -30,7 +31,7 @@ sha256sums=('SKIP'
'0c087d26e80333267391a6e9e34b95a2ffb103cb9391cb53cc5d97ad954af774'
'c5a3ec55f9d1bc52e5e5b127f76b7b16b79738268691a3e1d842359033e460da'
'2d17478fd607c75e396fe10ef2add8bc9fcc12054810fb6f4409dfb70e01989e'
- '2d66473febac0e142eb5b5b2b2c6341687b1afaa89c76ca4e6803499b60636f1')
+ '3159b78d6112f4e8906945d1adc1f33b6186d566b54a5976e3a684597c082942')
pkgver() {
cd pacman
diff --git a/makepkg.conf b/makepkg.conf
index 15c2f9ad978a..11372171ecce 100644
--- a/makepkg.conf
+++ b/makepkg.conf
@@ -37,8 +37,8 @@ CHOST="@CHOST@"
#-- Compiler and Linker Flags
CPPFLAGS="-D_FORTIFY_SOURCE=2"
-CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
-CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fno-plt"
+CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fno-plt"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"