summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-10-19 03:56:22 -0400
committerredfish2019-10-19 03:56:22 -0400
commit21e4ba3b6a43d5a74b85c16728f81a9c8b2d261c (patch)
tree031a532273ec51b8cb30129c809b98ac2d41c0c1
parentf238b618e5c67b1fd9db382c237b6459371fcf31 (diff)
downloadaur-21e4ba3b6a43d5a74b85c16728f81a9c8b2d261c.tar.gz
0.7.1
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD26
-rw-r--r--zeronet.conf3
-rw-r--r--zeronet.install4
-rw-r--r--zeronet.service2
5 files changed, 48 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8b0dbbf72c4..3679450cb873 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,40 @@
-# Generated by mksrcinfo v8
-# Mon Feb 18 01:30:54 UTC 2019
pkgbase = zeronet
pkgdesc = Decentralized websites using Bitcoin crypto and the BitTorrent network.
- pkgver = 0.6.5
+ pkgver = 0.7.1
pkgrel = 1
url = https://zeronet.io/
install = zeronet.install
arch = any
license = GPL2
- depends = python2
- depends = python2-gevent
- depends = python2-msgpack
+ checkdepends = python-pytest
+ checkdepends = python-mock
+ depends = python
+ depends = python-gevent>=1.1.0
+ depends = python-gevent-websocket
+ depends = python-msgpack>=0.4.4
+ depends = python-websocket-client
+ depends = python-rsa
+ depends = python-pysocks
+ depends = python-pyasn1
+ depends = python-pyasn1-modules
+ depends = python-base58
+ depends = python-merkletools
+ depends = python-pyelliptic>=2.0.1
+ depends = python-bencode.py
+ depends = python-coincurve
+ depends = python-bitcoinlib
+ depends = python-maxminddb
+ depends = geoip2-database
optdepends = tor: anonymity
+ optdepends = namecoin-core: local name resolution
options = !strip
backup = etc/zeronet.conf
- source = https://github.com/HelloZeroNet/ZeroNet/archive/v0.6.5.tar.gz
+ source = https://github.com/HelloZeroNet/ZeroNet/archive/v0.7.1.tar.gz
source = zeronet.conf
source = zeronet.service
- sha256sums = 28ca440099323ac307c6ed0afbaf607e4c1c47948917c0c97126a2ec6a293f51
- sha256sums = ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8
- sha256sums = 8e8df96340cb342b6262ac498292749e01ce5f713b03d5e31384b1f289d9ca62
+ sha256sums = 78a27e1687d8e3699a854b77b516c95b30a8ba667f7ebbef0aabf7ec6ec7272d
+ sha256sums = 289b4292b1a9346fbefc2bd8c2bb12c2fe7b5bc630dbdfabc778b0a23a16941c
+ sha256sums = 398965191fb95f78849d12ea6b8a2c475b702456c541e5971c77d11a47d15827
pkgname = zeronet
diff --git a/PKGBUILD b/PKGBUILD
index 8c94dc88e186..2f8f3daf0620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,21 @@
# Maintainer: redfish <redfish at galactica dot pw>
pkgname='zeronet'
-pkgver=0.6.5
+pkgver=0.7.1
pkgrel=1
arch=('any')
url="https://zeronet.io/"
-depends=('python2'
- 'python2-gevent'
- 'python2-msgpack')
-optdepends=('tor: anonymity')
+depends=('python' 'python-gevent>=1.1.0' 'python-gevent-websocket'
+ 'python-msgpack>=0.4.4' 'python-websocket-client' 'python-rsa'
+ 'python-pysocks' 'python-pyasn1' 'python-pyasn1-modules'
+ 'python-base58' 'python-merkletools'
+ 'python-pyelliptic>=2.0.1'
+ 'python-bencode.py' 'python-coincurve'
+ 'python-bitcoinlib' 'python-maxminddb'
+ 'geoip2-database')
+optdepends=('tor: anonymity'
+ 'namecoin-core: local name resolution')
+checkdepends=('python-pytest' 'python-mock')
license=('GPL2')
pkgdesc="Decentralized websites using Bitcoin crypto and the BitTorrent network."
source=("https://github.com/HelloZeroNet/ZeroNet/archive/v$pkgver.tar.gz"
@@ -33,6 +40,9 @@ package() {
install -D -m644 "$srcdir/$_pkgarchive/LICENSE" "$pkgdir/usr/share/licenses/$_pkgarchive/LICENSE"
}
-sha256sums=('28ca440099323ac307c6ed0afbaf607e4c1c47948917c0c97126a2ec6a293f51'
- 'ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8'
- '8e8df96340cb342b6262ac498292749e01ce5f713b03d5e31384b1f289d9ca62')
+sha256sums=('78a27e1687d8e3699a854b77b516c95b30a8ba667f7ebbef0aabf7ec6ec7272d'
+ '34c349ab5a233afd64e8a9c1d2140c7380fe6c730ed55fb08c6ca4c3a2fa6a89'
+ '398965191fb95f78849d12ea6b8a2c475b702456c541e5971c77d11a47d15827')
+sha256sums=('78a27e1687d8e3699a854b77b516c95b30a8ba667f7ebbef0aabf7ec6ec7272d'
+ '289b4292b1a9346fbefc2bd8c2bb12c2fe7b5bc630dbdfabc778b0a23a16941c'
+ '398965191fb95f78849d12ea6b8a2c475b702456c541e5971c77d11a47d15827')
diff --git a/zeronet.conf b/zeronet.conf
index b09d405c7086..67448ce54454 100644
--- a/zeronet.conf
+++ b/zeronet.conf
@@ -2,8 +2,9 @@
data_dir = /var/lib/zeronet
log_dir = /var/log/zeronet
+# Optionally, make node accessible from LAN
# ui_ip = *
-# ui_password = anypassword
+# ui_host = mylanhostname:43110
tor_controller = 127.0.0.1:9051
tor_proxy = 127.0.0.1:9050
diff --git a/zeronet.install b/zeronet.install
index 782f8a38df04..e14a0822ff5e 100644
--- a/zeronet.install
+++ b/zeronet.install
@@ -29,11 +29,11 @@ post_install() {
echo ">>> NOTE: all operations including editing zerosite files,"
echo ">>> should be done as user zeronet and config must be passed"
echo ">>> for data directory to be selected to /var/lib/zeronet: "
- echo ">>> sudo -u zeronet python2 zeronet.py --config_file /etc/zeronet.conf ..."
+ echo ">>> sudo -u zeronet python zeronet.py --config_file /etc/zeronet.conf ..."
echo ">>> OR"
echo ">>> sudo su - zeronet"
echo ">>> cd /opt/zeronet"
- echo ">>> python2 zeronet.py --config_file /etc/zeronet.conf ..."
+ echo ">>> python zeronet.py --config_file /etc/zeronet.conf ..."
}
## each separate version number must be less than 3 digit wide !
diff --git a/zeronet.service b/zeronet.service
index 24c09f5e4f84..e380fb652a5b 100644
--- a/zeronet.service
+++ b/zeronet.service
@@ -5,7 +5,7 @@ Description=Decentralized websites using Bitcoin crypto and the BitTorrent netwo
User=zeronet
Group=zeronet
WorkingDirectory=/opt/zeronet
-ExecStart=/usr/bin/env python2 zeronet.py --config_file /etc/zeronet.conf
+ExecStart=/usr/bin/env python zeronet.py --config_file /etc/zeronet.conf
SyslogIdentifier=zeronet
Restart=on-failure