summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordon Schulz2017-10-01 19:38:02 +0200
committerGordon Schulz2017-10-01 19:38:02 +0200
commit21f2e9d2614eecbfe96e17cbad284a89d4d5279d (patch)
treee753c9542fb197ab4a70b5248f30b621b913888f
parent07d88773e6403fe9099b0d2e86e6d5f61718e5f3 (diff)
downloadaur-21f2e9d2614eecbfe96e17cbad284a89d4d5279d.tar.gz
Updated PKGBUILD
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0489cd6226a2..77ae8c1bcefa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Maintainer: Gordon Schulz <gordon.schulz@gmail.com>
pkgname=physlock-git
-pkgver=0.4.5.r3.gb64dccc
+_pkgname='physlock'
+pkgver=v11.r16.g4f131cc
pkgrel=1
-pkgdesc="lightweight linux console locking tool (Git version)"
-arch=('i686' 'x86_64')
+pkgdesc="lightweight linux console locking tool"
+arch=(i686 x86_64)
license=('GPL')
-url='https://github.com/muennich/physlock'
+url="https://github.com/muennich/physlock"
+depends=(pam)
+makedepends=('git')
conflicts=('physlock')
-source=("${pkgname}::git+https://github.com/muennich/physlock.git#branch=master")
-md5sums=('SKIP')
+source=("${_pkgname}::git+${url}.git")
+sha512sums=('SKIP')
-pkgver () {
- cd "${srcdir}/${pkgname}"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+build() {
+ cd "${_pkgname}"
+ make PREFIX="/usr"
}
-build() {
- cd "${srcdir}/${pkgname}"
- make
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
package() {
- cd "${srcdir}/${pkgname}"
- make PREFIX=${pkgdir}/usr install
+ cd "$_pkgname"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
}
+