summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-10 03:24:43 -0600
committerLuis Martinez2021-03-10 03:25:09 -0600
commit21f3bed10636229e9bbc3f7709f590d687504edb (patch)
tree43eac82045ce7e6923c6cfb3a7cb3fa77488c776
downloadaur-21f3bed10636229e9bbc3f7709f590d687504edb.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE.md55
-rw-r--r--PKGBUILD20
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d923882231c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = as-tree-bin
+ pkgdesc = Print a list of paths as a tree of paths
+ pkgver = 0.12.0
+ pkgrel = 1
+ url = https://github.com/jez/as-tree
+ arch = x86_64
+ license = custom:BOML
+ depends = gcc-libs
+ source = as-tree-0.12.0.zip::https://github.com/jez/as-tree/releases/download/0.12.0/as-tree-0.12.0-linux.zip
+ source = LICENSE.md
+ sha256sums = adb3fa37c49bb137b772379a4c5e07c3ac9609871cd3058c376e32f9fb9ee434
+ sha256sums = 8a1af140fdfbf5afd3df27f7e662f989c5b963a300020dfafce42033cae9e004
+
+pkgname = as-tree-bin
+
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..c5402b9577a8
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,55 @@
+# Blue Oak Model License
+
+Version 1.0.0
+
+## Purpose
+
+This license gives everyone as much permission to work with
+this software as possible, while protecting contributors
+from liability.
+
+## Acceptance
+
+In order to receive this license, you must agree to its
+rules. The rules of this license are both obligations
+under that agreement and conditions to your license.
+You must not do anything with this software that triggers
+a rule that you cannot or will not follow.
+
+## Copyright
+
+Each contributor licenses you to do everything with this
+software that would otherwise infringe that contributor's
+copyright in it.
+
+## Notices
+
+You must ensure that everyone who gets a copy of
+any part of this software from you, with or without
+changes, also gets the text of this license or a link to
+<https://blueoakcouncil.org/license/1.0.0>.
+
+## Excuse
+
+If anyone notifies you in writing that you have not
+complied with [Notices](#notices), you can keep your
+license by taking all practical steps to comply within 30
+days after the notice. If you do not do so, your license
+ends immediately.
+
+## Patent
+
+Each contributor licenses you to do everything with this
+software that would otherwise infringe any patent claims
+they can license or become able to license.
+
+## Reliability
+
+No contributor can revoke this license.
+
+## No Liability
+
+***As far as the law allows, this software comes as is,
+without any warranty or condition, and no contributor
+will be liable to anyone for any damages related to this
+software or this license, under any kind of legal claim.***
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeb2aec297c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: lmartinez-mirror
+# Contributor: donbex <ap dot m at runbox dot com>
+pkgname=as-tree-bin
+_pkgname=${pkgname%-bin}
+pkgver=0.12.0
+pkgrel=1
+pkgdesc="Print a list of paths as a tree of paths"
+arch=('x86_64')
+url="https://github.com/jez/as-tree"
+license=('custom:BOML')
+depends=('gcc-libs')
+source=("$_pkgname-$pkgver.zip::$url/releases/download/$pkgver/$_pkgname-$pkgver-linux.zip"
+ "LICENSE.md")
+sha256sums=('adb3fa37c49bb137b772379a4c5e07c3ac9609871cd3058c376e32f9fb9ee434'
+ '8a1af140fdfbf5afd3df27f7e662f989c5b963a300020dfafce42033cae9e004')
+
+package() {
+ install -Dm 755 as-tree -t "$pkgdir/usr/bin"
+ install -Dm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+}