summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-11-03 21:30:49 -0500
committerGuillaume Horel2019-11-03 21:30:49 -0500
commit21f9f5633690b1260eec1ea6b3de2a95576448aa (patch)
tree3ca6d0617edb85665268830ed7eb2a88bd3294d6
downloadaur-21f9f5633690b1260eec1ea6b3de2a95576448aa.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4bfa26ca601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bcunit-git
+ pkgdesc = A fork of CUnit, a C unit testing framework
+ pkgver = 3.0.2.r11.g966505d
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ provides = bcunit
+ conflicts = bcunit
+ source = git+https://gitlab.linphone.org/BC/public/bcunit.git
+ sha256sums = SKIP
+
+pkgname = bcunit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ddfe0d56f2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=bcunit-git
+_pkgname=bcunit
+pkgver=3.0.2.r11.g966505d
+pkgrel=1
+pkgdesc="A fork of CUnit, a C unit testing framework"
+arch=('x86_64')
+url="http://www.linphone.org/"
+license=('GPL')
+depends=()
+makedepends=('cmake')
+provides=('bcunit')
+conflicts=('bcunit')
+source=("git+https://gitlab.linphone.org/BC/public/bcunit.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC=NO \
+ "../$_pkgname"
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}