summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Costa2018-02-06 09:57:40 -0200
committerNarrat2018-02-07 21:45:17 +0100
commit2224ad8db4b1c73b47514de0a887ede5e42dbba6 (patch)
tree63591cc49554d9273c260c3b0313263d745474ed
parent36b3a323adff25efb679571ba1d173f1dee3a61e (diff)
downloadaur-2224ad8db4b1c73b47514de0a887ede5e42dbba6.tar.gz
Always use latest sources
edited by Narrat
-rw-r--r--01_openssl102.patch4
-rw-r--r--02_freetype.patch4
-rw-r--r--PKGBUILD16
3 files changed, 15 insertions, 9 deletions
diff --git a/01_openssl102.patch b/01_openssl102.patch
index 32b109f7f03a..da2cd559e70d 100644
--- a/01_openssl102.patch
+++ b/01_openssl102.patch
@@ -1,5 +1,5 @@
---- tibia-11.57.6239/start-tibia.sh
-+++ tibia-11.57.6239/start-tibia.sh
+--- start-tibia.sh
++++ start-tibia.sh
@@ -7,4 +7,4 @@
PATH=$(dirname "$SCRIPT")
BIN_PATH="$PATH/bin"
diff --git a/02_freetype.patch b/02_freetype.patch
index a84476788b6b..19a858d84b27 100644
--- a/02_freetype.patch
+++ b/02_freetype.patch
@@ -1,5 +1,5 @@
---- tibia-11.57.6239/start-tibia.sh
-+++ tibia-11.57.6239/start-tibia.sh
+--- start-tibia.sh
++++ start-tibia.sh
@@ -6,5 +6,6 @@
SCRIPT=$(readlink -f "$0")
PATH=$(dirname "$SCRIPT")
diff --git a/PKGBUILD b/PKGBUILD
index f272822354d5..60d4925dbf28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
pkgname=tibia
-pkgver=11.57.6239
+pkgver=11.58.6239
pkgrel=1
pkgdesc="fast-paced free massively multiplayer online role-playing game"
arch=('x86_64')
@@ -10,26 +10,32 @@ license=('custom')
depends=('glu' 'libgl' 'libice' 'libxext' 'openssl-1.0' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
-source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
+source=("${pkgname}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
"${pkgname}-agreement.php::http://www.tibia.com/support/agreement.php"
"01_openssl102.patch"
"02_freetype.patch")
-sha256sums=('ebbd21d4a4c88ca51e16ed7d8a3bf655943d0263db7c975ab7f1709714eb8875'
+sha256sums=('SKIP'
'965edf1cf67698f9dcfcbced495e0e96a666207a9a0b91fb769ed386a5f1efe5'
- 'ad1d236ac5d75f053be3d0bfd94e340e098a063487c6f57593a4bffb67fdc67c'
- '6a4431cafa196fa76d7c7da9bc082a8e43becb9f20fc28db3952359623bbe636')
+ '3d55ac564bb2edc8fe7e826743a774b2191d29a1905bb35e9d9b26528c7a0fe6'
+ '554748e5e81ab9c693d118d6e6e28408062cdd2a1efc3a1a60a4f13edbcc91a6')
prepare() {
gendesk -f -n
html2text "${pkgname}-agreement.php" > LICENSE
+ # Patching
+ cd -- $(find . -maxdepth 1 -type d -iname tibia-\* -print -quit)
# Tibia relies on openssl 1.0.x
patch -Np0 -i "${srcdir}/01_openssl102.patch"
# Tibia relies on specific freetype version
patch -Np0 -i "${srcdir}/02_freetype.patch"
}
+pkgver() {
+ find . -maxdepth 1 -type d -iname tibia-\* -print -quit | sed 's/\.\/tibia-\(.*\)/\1/'
+}
+
package() {
mkdir -p "${pkgdir}/opt/Tibia"
cp -drv --no-preserve=ownership ${pkgname}-${pkgver}/* "${pkgdir}/opt/Tibia"