summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-02-26 13:08:09 -0300
committerDaniel Bermond2024-02-26 13:08:09 -0300
commit224de1aba975d1c412bf28ac346497772dd9c7aa (patch)
tree0167371d9f9a6d5f51835768fb892aa013c8f563
parent0e815819ec0193c133d2b6e1534f6bbfce8d3ec3 (diff)
downloadaur-224de1aba975d1c412bf28ac346497772dd9c7aa.tar.gz
Add patch for glslang 14
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e4c8ce11264..0722dfd3a5be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = ffmpeg-full
pkgdesc = Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
pkgver = 6.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.ffmpeg.org/
arch = x86_64
- license = custom: nonfree and unredistributable
+ license = LicenseRef-nonfree-and-unredistributable
makedepends = clang
makedepends = amf-headers
makedepends = ffnvcodec-headers
@@ -145,6 +145,7 @@ pkgbase = ffmpeg-full
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
source = 070-ffmpeg-fix-lensfun-detection.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e1c1dc8347f13104bc21e4100fcf4d4dddf5e5d8
+ source = 080-ffmpeg-glslang14-fix.patch::https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e43615fc2ab27d562ed7e087803f4a364a7d1175
source = LICENSE
validpgpkeys = FCF986EA15E6E293A5644F10B4322F04D67658D8
sha256sums = 8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968
@@ -155,6 +156,7 @@ pkgbase = ffmpeg-full
sha256sums = 7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1
sha256sums = 0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440
sha256sums = 2b72fe52ea73fbc1ce7eb70b4c181893c761e30121879ddd5513976232d7adf8
+ sha256sums = cebcc04cac957f6a9c08169765da4c7ef231ebbda225876e210fd60e8582c3d9
sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-full
diff --git a/PKGBUILD b/PKGBUILD
index 9c810cf279fd..1f424719caeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ffmpeg-full
pkgver=6.1.1
-pkgrel=1
+pkgrel=2
_svt_hevc_ver='6cca5b932623d3a1953b165ae6b093ca1325ac44'
_svt_vp9_ver='43ef8e5e96932421858762392adbbab57c84aebf'
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
-license=('custom: nonfree and unredistributable')
+license=('LicenseRef-nonfree-and-unredistributable')
depends=(
'alsa-lib'
'aom'
@@ -140,6 +140,7 @@ source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'070-ffmpeg-fix-lensfun-detection.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e1c1dc8347f13104bc21e4100fcf4d4dddf5e5d8'
+ '080-ffmpeg-glslang14-fix.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/e43615fc2ab27d562ed7e087803f4a364a7d1175'
'LICENSE')
sha256sums=('8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968'
'SKIP'
@@ -149,6 +150,7 @@ sha256sums=('8684f4b00f94b85461884c3719382f1261f0d9eb3d59640a1f4ac0873616f968'
'7d5ce8058b143bae1be10a06d79ac0f1a72daf00cf648309450d83bea249a6b1'
'0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440'
'2b72fe52ea73fbc1ce7eb70b4c181893c761e30121879ddd5513976232d7adf8'
+ 'cebcc04cac957f6a9c08169765da4c7ef231ebbda225876e210fd60e8582c3d9'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -160,6 +162,7 @@ prepare() {
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/070-ffmpeg-fix-lensfun-detection.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/080-ffmpeg-glslang14-fix.patch"
}
build() {
@@ -242,6 +245,7 @@ build() {
--enable-librsvg \
--enable-librubberband \
--enable-librtmp \
+ --disable-libshaderc \
--enable-libshine \
--enable-libsmbclient \
--enable-libsnappy \