summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-27 09:42:32 +0800
committerzxp198210052023-04-27 09:42:32 +0800
commit2288aa5202daea29a49409d7913c9c6e7d3c4998 (patch)
treec06cfcad62109725f9f3198fa198951c47760075
parent980a091cca9585d2bf204bcae8a317780159b378 (diff)
downloadaur-2288aa5202daea29a49409d7913c9c6e7d3c4998.tar.gz
update to 0.2.3-alpha
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 24 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bb295aa02f9..0ca8b61e9c99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = remoteplaywhatever-bin
pkgdesc = Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones.
- pkgver = 0.2.2
+ pkgver = 0.2.3alpha
pkgrel = 1
url = https://github.com/m4dEngi/RemotePlayWhatever
arch = x86_64
- depends = wxwidgets-common
- depends = wxwidgets-gtk3
- depends = libtiff5
- provides = remoteplaywhatever
- source = remoteplaywhatever-bin-0.2.2.deb::https://github.com/m4dEngi/remoteplaywhatever/releases/download/0.2.2-alpha/remoteplaywhatever-0.2.2-Linux.deb
- sha512sums = 6266329ecce60f11d8b3fcf1e31cc9f16a1f9c222f0f8ede7fb15eb837846d3e97cc03a428244a2f73c6fedd3226e09b5ada5a5ae715965d55035054109eeadd
+ license = MIT
+ depends = gcc-libs
+ depends = glibc
+ conflicts = remoteplaywhatever
+ options = !strip
+ source = remoteplaywhatever-0.2.3alpha.deb::https://github.com/m4dEngi/RemotePlayWhatever/releases/download/0.2.3-alpha/RemotePlayWhatever-0.2.3-Linux.deb
+ source = LICENSE::https://github.com/m4dEngi/RemotePlayWhatever/raw/master/LICENSE
+ sha256sums = 06de4747350c6c2c98457f2d65929242cccc652bfccf5d7240a8c617cbb7b400
+ sha256sums = 284724acc9bb9b5a0579ca01589605ad6d8b4cd01094d7077ca6308aa5786cdd
pkgname = remoteplaywhatever-bin
diff --git a/PKGBUILD b/PKGBUILD
index 880d7a035f07..54956f84d2b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,20 @@
# Maintainer: Rojikku <RojikkuNoKami at gmail dot com>
-_pkgname=remoteplaywhatever
-pkgname=${_pkgname}-bin
-pkgver=0.2.2
+pkgname=remoteplaywhatever-bin
+pkgver=0.2.3alpha
pkgrel=1
pkgdesc="Tiny application that lets you force remote play together any game you have in your steam library including non-steam ones."
arch=('x86_64')
+license=('MIT')
url="https://github.com/m4dEngi/RemotePlayWhatever"
-provides=('remoteplaywhatever')
-depends=('wxwidgets-common' 'wxwidgets-gtk3' 'libtiff5')
-source=(
- ${pkgname}-${pkgver}.deb::https://github.com/m4dEngi/${_pkgname}/releases/download/${pkgver}-alpha/${_pkgname}-${pkgver}-Linux.deb
-)
-sha512sums=('6266329ecce60f11d8b3fcf1e31cc9f16a1f9c222f0f8ede7fb15eb837846d3e97cc03a428244a2f73c6fedd3226e09b5ada5a5ae715965d55035054109eeadd')
-
-prepare() {
- cd "$srcdir"
- tar xvf data.tar.gz
-}
-
+provides=()
+conflicts=("${pkgname%-bin}")
+depends=('gcc-libs' 'glibc')
+options=(!strip)
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver%alpha}-alpha/RemotePlayWhatever-${pkgver%alpha}-Linux.deb"
+ "LICENSE::${url}/raw/master/LICENSE")
+sha256sums=('06de4747350c6c2c98457f2d65929242cccc652bfccf5d7240a8c617cbb7b400'
+ '284724acc9bb9b5a0579ca01589605ad6d8b4cd01094d7077ca6308aa5786cdd')
package() {
- cd "$srcdir/usr/bin"
-
- # binary
- install -D -m0755 remoteplaywhatever "${pkgdir}/usr/bin/remoteplaywhatever"
-
-}
-
+ bsdtar -xf "${srcdir}/data.tar.gz" -C "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file