summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-08-16 17:35:25 -0500
committerCarlos Aznarán Laos2023-08-16 17:35:25 -0500
commit22dec212133536fbbd1de49e9550a33f4d157603 (patch)
treedb1469123b0067104ad8154379f0b1bba7b91558
parenta05ee7bde0f8a5f8cd3b864322a6d7eed79899d4 (diff)
downloadaur-22dec212133536fbbd1de49e9550a33f4d157603.tar.gz
Bump version to 3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bee78cebe4a..df23cbb4b07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-pyviz_comms
pkgdesc = Bidirectional communication for the PyViz ecosystem
- pkgver = 2.3.2
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/pyviz/pyviz_comms
arch = any
license = custom:BSD-3-clause
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
+ makedepends = python-hatchling
makedepends = python-wheel
depends = python-param
depends = jupyterlab
- source = https://pypi.org/packages/source/p/pyviz_comms/pyviz_comms-2.3.2.tar.gz
- sha512sums = 17c6c9888924142330258f46311ec148a55c0b6b6487cc85f0425dd902f2dc0ec08fae0ad9cf36c90f8c36bc7d4d680c860334670a5d4a4194c553c75b8e0fdc
+ source = https://pypi.org/packages/source/p/pyviz_comms/pyviz_comms-3.0.0.tar.gz
+ sha512sums = 4c17e05efb7680e5f4d2d1430b4d1a1834c19f29affe029e25c0cb3891bc94b177b1437625626d577cee893b62e95b885700b7645b7e44d01348e28f4a871ed5
pkgname = python-pyviz_comms
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e0b98a084db5..59fc110db705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_base=pyviz_comms
pkgname=python-${_base}
pkgdesc="Bidirectional communication for the PyViz ecosystem"
-pkgver=2.3.2
+pkgver=3.0.0
pkgrel=1
arch=(any)
url="https://github.com/pyviz/${_base}"
license=('custom:BSD-3-clause')
depends=(python-param jupyterlab)
-makedepends=(python-build python-installer python-setuptools python-wheel)
+makedepends=(python-build python-installer python-hatchling python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
-sha512sums=('17c6c9888924142330258f46311ec148a55c0b6b6487cc85f0425dd902f2dc0ec08fae0ad9cf36c90f8c36bc7d4d680c860334670a5d4a4194c553c75b8e0fdc')
+sha512sums=('4c17e05efb7680e5f4d2d1430b4d1a1834c19f29affe029e25c0cb3891bc94b177b1437625626d577cee893b62e95b885700b7645b7e44d01348e28f4a871ed5')
build() {
cd ${_base}-${pkgver}