summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:34:47 -0700
committerShadowKyogre2015-06-08 07:34:47 -0700
commit22e06ca7227554aada8e180d8d9f49181d499415 (patch)
treeafe63fc7896266a0d90fe241b27f4ac0eef67df5
downloadaur-22e06ca7227554aada8e180d8d9f49181d499415.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eac72415c028
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pyswisseph3
+ pkgdesc = Python extension to the Swiss Ephemeris. (Python 3 version)
+ pkgver = 1.77.00
+ pkgrel = 1
+ url = http://pyswisseph.chaosorigin.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python
+ source = http://pypi.python.org/packages/source/p/pyswisseph/pyswisseph-1.77.00-0.tar.bz2
+ md5sums = 3ce9b9a013430d2d28f6c2f5a4f8a67f
+
+pkgname = pyswisseph3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..907f43601b15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+_orig=pyswisseph
+pkgname='pyswisseph3'
+pkgver='1.77.00'
+pkgrel='1'
+pkgdesc='Python extension to the Swiss Ephemeris. (Python 3 version)'
+arch=('i686' 'x86_64')
+license=('GPL')
+url=('http://pyswisseph.chaosorigin.com/')
+depends=('python')
+#makedepends=()
+#optdepends=()
+source=("http://pypi.python.org/packages/source/p/${_orig}/${_orig}-${pkgver}-0.tar.bz2")
+md5sums=('3ce9b9a013430d2d28f6c2f5a4f8a67f')
+
+package() {
+ cd "$srcdir/${_orig}-$pkgver-0"
+ python setup.py install --root=$pkgdir || return 1
+}