summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFedor Piecka2021-08-17 10:51:53 +0200
committerFedor Piecka2021-08-17 10:51:53 +0200
commit22f76ab735708bcbb32033948c42088a65325d42 (patch)
tree09758217cc0af05d64d8cf99291d7105032d3ff0
parent5103b702cd26dab33f8c899441383d45feea3d88 (diff)
downloadaur-22f76ab735708bcbb32033948c42088a65325d42.tar.gz
Switch to Ubuntu version
Disig-web-signer 2 from Debian package crashes on Arch (probably because of an additional OpenSSL 1.0.0 dependency).
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
-rw-r--r--disig-web-signer.install12
3 files changed, 16 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d448ae0eca1..2c52edfedf04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = disig-web-signer
pkgdesc = Slovak eID Web Signer by Disig
pkgver = 2.0.7
- pkgrel = 2
+ pkgrel = 3
url = https://zep.disig.sk/
- install = disig-web-signer.install
arch = i686
arch = x86_64
license = custom
options = !strip
- source_i686 = https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_i386.deb
+ source_i686 = https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_i386.deb
md5sums_i686 = SKIP
- source_x86_64 = https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_amd64.deb
+ source_x86_64 = https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_amd64.deb
md5sums_x86_64 = SKIP
pkgname = disig-web-signer
@@ -18,5 +17,4 @@ pkgname = disig-web-signer
depends = gcc-libs
depends = mesa
depends = qt5-base
- depends = openssl-1.0
-
+ depends = qt5-websockets
diff --git a/PKGBUILD b/PKGBUILD
index 8f83b2f54c24..d49200b47174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
pkgname=disig-web-signer
pkgver=2.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Slovak eID Web Signer by Disig"
arch=('i686' 'x86_64')
license=('custom')
url="https://zep.disig.sk/"
-source_i686=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_i386.deb')
-source_x86_64=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.debian_amd64.deb')
+source_i686=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_i386.deb')
+source_x86_64=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_amd64.deb')
md5sums_i686=('SKIP')
md5sums_x86_64=('SKIP')
options=("!strip")
-install="disig-web-signer.install"
# Upstream uses Debian architecture naming convention. Let's prepare a variable for that.
upstream_arch=
@@ -22,24 +21,18 @@ upstream_arch=
pkgver() {
# Match Debian package version
- ar p ${srcdir}/disig-web-signer.debian_${upstream_arch}.deb control.tar.gz | tar -Oxz ./control | grep ^Version: | cut -f2 -d" " | tr -d '[:space:]' | cut -f1 -d"-"
+ ar p ${srcdir}/disig-web-signer.ubuntu_${upstream_arch}.deb control.tar.gz | tar -Oxz ./control | grep ^Version: | cut -f2 -d" " | tr -d '[:space:]' | cut -f1 -d"-"
}
package() {
- depends=("glibc" "gcc-libs" "mesa" "qt5-base" "openssl-1.0")
+ depends=("glibc" "gcc-libs" "mesa" "qt5-base" "qt5-websockets")
- ar p ${srcdir}/disig-web-signer.debian_${upstream_arch}.deb data.tar.xz | tar -xJ -C "${pkgdir}"
-
- # Create a native messaging host for Google Chrome browser and Chromium; this is done by a postinst script in upstream Debian package
- native_messaging_host_filename=$(basename $(find ${pkgdir}/opt/disig/websigner/chrome/ -name sk.disig.websigner.*.java.json))
-
- mkdir -p ${pkgdir}/etc/opt/chrome/native-messaging-hosts
- ln -sf /opt/disig/websigner/chrome/${native_messaging_host_filename} ${pkgdir}/etc/opt/chrome/native-messaging-hosts/${native_messaging_host_filename}
-
- mkdir -p ${pkgdir}/etc/chromium/native-messaging-hosts/
- ln -sf /opt/disig/websigner/chrome/${native_messaging_host_filename} ${pkgdir}/etc/chromium/native-messaging-hosts/${native_messaging_host_filename}
-
- # Let autostart configuration up to a user's discretion
- # rm -r ${pkgdir}/etc/xdg
+ ar p ${srcdir}/disig-web-signer.ubuntu_${upstream_arch}.deb data.tar.xz | tar -xJ -C "${pkgdir}"
+ # Create a native messaging host for Google Chrome browser and Chromium; this is done by a postinst script in upstream deb package
+ mkdir -p ${pkgdir}/etc/opt/chrome/native-messaging-hosts ${pkgdir}/etc/chromium/native-messaging-hosts
+ for file in ${pkgdir}/opt/disig/websigner/chrome/sk.disig.websigner.*.json ; do
+ ln -sf "${file}" ${pkgdir}/etc/opt/chrome/native-messaging-hosts/
+ ln -sf "${file}" ${pkgdir}/etc/chromium/native-messaging-hosts/
+ done
}
diff --git a/disig-web-signer.install b/disig-web-signer.install
deleted file mode 100644
index 572b9d0be368..000000000000
--- a/disig-web-signer.install
+++ /dev/null
@@ -1,12 +0,0 @@
-# post_install() {
-# echo ">>> disig-web-signer browser addon has NOT been installed into Firefox."
-# echo ">>> You can install the plugin into Firefox from the following location:"
-# echo -n ">>> "
-# ls /opt/disig/websigner/firefox/*.xpi
-# }
-
-# post_upgrade() {
-# echo ">>> You may need to upgrade the Firefox addon for disig-web-signer if you use it:"
-# echo -n ">>> "
-# ls /opt/disig/websigner/firefox/*.xpi
-# }