summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2018-06-27 13:59:26 -0400
committerStorm Dragon2018-06-27 13:59:26 -0400
commit230d77021cee727e66639784213586076513eccb (patch)
tree40ee4ae5860ba8dba1f108c698ae47a870bf5e87
downloadaur-230d77021cee727e66639784213586076513eccb.tar.gz
initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
-rw-r--r--gama_tts-git.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38edaa319584
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Jun 27 17:58:56 UTC 2018
+pkgbase = gama_tts-git
+ pkgdesc = An articulatory synthesizer that converts text to speech.
+ pkgver = v0.8
+ pkgrel = 1
+ url = https://gitlab.com/mym-br/gama_tts
+ install = gama_tts-git.install
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ provides = gama_tts
+ conflicts = gama_tts
+ source = git+https://gitlab.com/mym-br/gama_tts.git
+ sha256sums = SKIP
+
+pkgname = gama_tts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..409f1e5e4b47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+
+_gitname='gama_tts'
+pkgname="$_gitname"-git
+pkgver=v0.8
+pkgrel=1
+pkgdesc='An articulatory synthesizer that converts text to speech.'
+arch=('armv7h' 'i686' 'x86_64')
+url='https://gitlab.com/mym-br/gama_tts'
+license=('GPL3')
+makedepends=('cmake' 'git')
+provides=("$_gitname")
+conflicts=("$_gitname")
+install="$pkgname".install
+source=("git+https://gitlab.com/mym-br/$_gitname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ local ver="$(git describe --tags)"
+ echo "${ver//-/.}"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ cmake -D CMAKE_BUILD_TYPE=Release .
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+# vim: set ts=2 sw=2 et:
diff --git a/gama_tts-git.install b/gama_tts-git.install
new file mode 100644
index 000000000000..290ececb7bf1
--- /dev/null
+++ b/gama_tts-git.install
@@ -0,0 +1,11 @@
+post_install() {
+_alert
+}
+
+_alert() {
+cat -s << EOF
+Usage:
+echo "Hello world" | gama_tts tts /usr/local/share/gama_tts/data/english/vtmX test.wav
+Where X is a number from 0 to 5.
+EOF
+}