aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Alex2020-09-03 17:42:22 +1000
committerBen Alex2020-09-03 17:42:22 +1000
commit2314b46b17f93ec81cb20e6194a81821c0821776 (patch)
tree1c3fff84cd1e5961437152c9cb21455dba87e2fc
parent91b8566eb10e352eef426a88510ee5658ae14b56 (diff)
downloadaur-2314b46b17f93ec81cb20e6194a81821c0821776.tar.gz
Upload script to include version number in commit message
-rwxr-xr-xupload3
1 files changed, 2 insertions, 1 deletions
diff --git a/upload b/upload
index 95f9a497ac51..f94e94cb7b5f 100755
--- a/upload
+++ b/upload
@@ -17,6 +17,7 @@ $SCRIPT_HOME/update
if [ "$?" -eq 1 ]; then
echo "Updating Git"
cd $SCRIPT_HOME
- git commit -a -m "Commit from upload script due to new version"
+ ver="$(grep pkgver= PKGBUILD | sed 's/.*=//g')"
+ git commit -a -m "Update to $ver"
git push
fi