summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2016-05-03 23:35:42 +0200
committerMichele Mocciola2016-05-03 23:35:42 +0200
commit23457245b714bc84dde8e43e69ef0f64eff58ad8 (patch)
tree6f9196f57fa126d0841ce4e2d7e8c77cbc1538de
parent375ba0f14fa94a2ca2d388bb9da9aff5bd918c4a (diff)
downloadaur-23457245b714bc84dde8e43e69ef0f64eff58ad8.tar.gz
updated to osg-3.4.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--osg340.patch32
3 files changed, 40 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10ad5b323686..6b99ef0d8125 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue May 3 21:35:12 UTC 2016
pkgbase = ifcplusplus-git
pkgdesc = Port of IfcPlusPlus on linux. IfcPlusPlus is an open source C++ class model, as well as a reader and writer for IFC files in STEP format.
pkgver = 0.r161.g73d0b99
@@ -13,8 +15,10 @@ pkgbase = ifcplusplus-git
depends = qt5-base
source = IfcPlusPlus::git://github.com/berndhahnebach/IfcPlusPlus.git
source = qt5.patch
+ source = osg340.patch
md5sums = SKIP
md5sums = 3df56628d79a15799aede92466db77a3
+ md5sums = 70c0472dac19f4be7c8984cfcdbe54f2
pkgname = ifcplusplus-git
diff --git a/PKGBUILD b/PKGBUILD
index 4fa4c0379d44..901c4e4e3333 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ makedepends=('boost' 'chrpath')
conflicts=()
replaces=()
backup=()
-source=('IfcPlusPlus::git://github.com/berndhahnebach/IfcPlusPlus.git' 'qt5.patch')
+source=('IfcPlusPlus::git://github.com/berndhahnebach/IfcPlusPlus.git' 'qt5.patch' 'osg340.patch')
pkgver() {
cd IfcPlusPlus
@@ -27,6 +27,7 @@ pkgver() {
prepare() {
cd "${srcdir}/IfcPlusPlus"
patch -Np1 -i "${srcdir}/qt5.patch"
+ patch -Np1 -i "${srcdir}/osg340.patch"
}
build() {
@@ -47,4 +48,5 @@ package() {
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
md5sums=('SKIP'
- '3df56628d79a15799aede92466db77a3')
+ '3df56628d79a15799aede92466db77a3'
+ '70c0472dac19f4be7c8984cfcdbe54f2')
diff --git a/osg340.patch b/osg340.patch
new file mode 100644
index 000000000000..b28f4dff4296
--- /dev/null
+++ b/osg340.patch
@@ -0,0 +1,32 @@
+diff -Naur IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h
+--- IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h 2016-05-03 22:48:45.167336967 +0200
++++ IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/ConverterOSG.h 2016-05-03 22:59:10.007285252 +0200
+@@ -481,10 +481,9 @@
+ const osg::Geode* child_geode = dynamic_cast<const osg::Geode*>( node );
+ if( child_geode )
+ {
+- const osg::Geode::DrawableList& drawable_list = child_geode->getDrawableList();
+- for( auto it_drawables = drawable_list.begin(); it_drawables != drawable_list.end(); ++it_drawables )
++ for( int i=0; i < child_geode->getNumDrawables(); ++i )
+ {
+- osg::Drawable* drawable = ( *it_drawables );
++ const osg::Drawable* drawable = child_geode->getDrawable(i);
+ const osg::Geometry* child_gemetry = dynamic_cast<const osg::Geometry*>( drawable );
+ if( !child_gemetry )
+ {
+diff -Naur IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h
+--- IfcPlusPlus.orig/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h 2016-05-03 22:48:45.167336967 +0200
++++ IfcPlusPlus/IfcPlusPlus/src/ifcpp/geometry/GeomUtils.h 2016-05-03 22:59:51.353727925 +0200
+@@ -1223,10 +1223,9 @@
+ continue;
+ }
+ set_applied.insert( child_geode );
+- const osg::Geode::DrawableList& drawable_list = child_geode->getDrawableList();
+- for( osg::Geode::DrawableList::const_iterator it_drawables = drawable_list.begin(); it_drawables != drawable_list.end(); ++it_drawables )
++ for( int i=0; i < child_geode->getNumDrawables(); ++i )
+ {
+- osg::Drawable* drawable = ( *it_drawables );
++ osg::Drawable* drawable = child_geode->getDrawable(i);
+ osg::Geometry* child_geometry = dynamic_cast<osg::Geometry*>( drawable );
+ if( !child_geometry )
+ {