summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Flemström2017-03-30 13:18:22 -0400
committerDavid Flemström2017-03-30 13:18:22 -0400
commit236115696ed676230865e10fecf6ad2ce3cf8140 (patch)
tree5d1c66c91b3b4450f45ea376aca7d2150321f2fe
downloadaur-236115696ed676230865e10fecf6ad2ce3cf8140.tar.gz
Initial implementation
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD53
-rwxr-xr-xstyx2
-rw-r--r--styx-cli-git.install4
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c39e4c11801
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Mar 30 17:15:05 UTC 2017
+pkgbase = styx-cli-git
+ pkgdesc = The command-line interface to Spotify Styx
+ pkgver = v1.0.0.r5.gb7a993e
+ pkgrel = 1
+ url = https://github.com/spotify/styx
+ install = styx-cli-git.install
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = maven
+ depends = java-runtime
+ source = styx-cli-git::git+https://github.com/spotify/styx.git
+ source = styx-cli-git.install
+ source = styx
+ md5sums = SKIP
+ md5sums = 8b90d3191621f29fd431ecc53d9fb1d9
+ md5sums = b23e6239c26c8c5ff70f678466a2c976
+
+pkgname = styx-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..761c65b90c00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: <dflemstr@dflemstr-laptop>
+pkgname=styx-cli-git
+pkgver=v1.0.0.r5.gb7a993e
+pkgrel=1
+epoch=
+pkgdesc="The command-line interface to Spotify Styx"
+arch=('any')
+url="https://github.com/spotify/styx"
+license=('Apache')
+groups=()
+depends=('java-runtime')
+makedepends=('git' 'maven')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=styx-cli-git.install
+changelog=
+source=("$pkgname::git+https://github.com/spotify/styx.git"
+ 'styx-cli-git.install'
+ 'styx')
+noextract=()
+md5sums=('SKIP'
+ '8b90d3191621f29fd431ecc53d9fb1d9'
+ 'b23e6239c26c8c5ff70f678466a2c976')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ mvn package -am -pl styx-cli -Dmaven.test.skip -Dmaven.javadoc.skip
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ mvn verify -am -pl styx-cli
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 styx -t "$pkgdir/usr/bin"
+
+ cd "$pkgname"
+ install -Dm644 styx-cli/target/styx-cli.jar -t "$pkgdir/usr/share/styx-cli"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/styx b/styx
new file mode 100755
index 000000000000..78235501ebb7
--- /dev/null
+++ b/styx
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec java -jar /usr/share/styx-cli/styx-cli.jar "$@"
diff --git a/styx-cli-git.install b/styx-cli-git.install
new file mode 100644
index 000000000000..94e3cb05b50a
--- /dev/null
+++ b/styx-cli-git.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo '>>> You need to set STYX_CLI_HOST to something reasonable'
+ echo '>>> for the styx command to work'
+}