summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-01-09 10:14:16 -0800
committerShadowKyogre2016-01-09 10:19:38 -0800
commit237eeea85a10c72defa09aa09275416c8b3201c3 (patch)
tree588d157ae9aafcd808a7747ef4b55faf7340e71b
parent64b49a8ed347d8dded833d6850a5c7a2c3e7969a (diff)
downloadaur-237eeea85a10c72defa09aa09275416c8b3201c3.tar.gz
Update with insert mode patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--fbterm-insertmode.patch11
3 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa5a251286a8..26dcea314926 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 18:13:36 UTC 2016
pkgbase = fbterm-git
pkgdesc = A fast framebuffer-based terminal emulator for Linux
pkgver = 20150509
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/izmntuk/fbterm
- install = INSTALL
+ install = fbterm-git.install
arch = x86_64
arch = i686
license = GPL2
@@ -15,9 +17,9 @@ pkgbase = fbterm-git
provides = fbterm
conflicts = fbterm
source = git+https://github.com/izmntuk/fbterm
- source = INSTALL
- sha1sums = SKIP
+ source = fbterm-insertmode.patch
sha1sums = SKIP
+ sha1sums = 11b95e4a90519156bc02dc0fa3b086f37820431b
pkgname = fbterm-git
diff --git a/PKGBUILD b/PKGBUILD
index f1daff42e940..84ffaff51211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,25 @@ conflicts=('fbterm')
provides=('fbterm')
optdepends=('libx86: accelerator with VESA compatible video card' 'gpm: mouse selection support')
install="${pkgname}.install"
-source=('git+https://github.com/izmntuk/fbterm')
-sha1sums=(SKIP)
+source=(
+ 'git+https://github.com/izmntuk/fbterm'
+ 'fbterm-insertmode.patch'
+)
+sha1sums=(
+ 'SKIP'
+ '11b95e4a90519156bc02dc0fa3b086f37820431b'
+)
pkgver() {
cd "${srcdir}/fbterm"
git log -1 --format="%cd" --date=short | sed 's|-||g'
}
+prepare() {
+ cd "${srcdir}/fbterm"
+ patch -Np1 -i "${srcdir}/fbterm-insertmode.patch"
+}
+
build() {
cd "${srcdir}/fbterm"
./configure --prefix=/usr
diff --git a/fbterm-insertmode.patch b/fbterm-insertmode.patch
new file mode 100644
index 000000000000..6bb3cd361d9d
--- /dev/null
+++ b/fbterm-insertmode.patch
@@ -0,0 +1,11 @@
+--- fbterm-1.7/src/lib/vterm.cpp.orig 2010-10-06 08:23:08.000000000 +0400
++++ fbterm-1.7/src/lib/vterm.cpp 2015-10-23 15:08:22.247733126 +0300
+@@ -445,7 +445,7 @@ void VTerm::do_normal_char()
+ changed_line(cursor_y, cursor_x, width - 1);
+
+ u16 step = dw ? 2 : 1;
+- for (u16 i = width - step - 1; i >= cursor_x; i--) {
++ for (s32 i = width - step - 1; i >= cursor_x; i--) {
+ text[yp + i + step] = text[yp + i];
+ attrs[yp + i + step] = attrs[yp + i];
+ }