summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-08 22:28:42 +0100
committerFelix Golatofski2020-01-08 22:28:42 +0100
commit238eb6b4d882cfd17d5241f5416e512ebd813a00 (patch)
treefc55ddc41d249b057a3a02fa06d0a6553dc9d7bf
parente3207e955d83798325a97a4fffd9239bafd26b30 (diff)
downloadaur-238eb6b4d882cfd17d5241f5416e512ebd813a00.tar.gz
Updated to 1.1.1d
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD64
-rw-r--r--ca-dir.patch21
-rw-r--r--no-rpath.patch11
4 files changed, 46 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0a4e8d2ccac..604641b9ed36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,21 @@
-# Generated by mksrcinfo v8
-# Thu Feb 23 03:55:31 UTC 2017
pkgbase = openssl-pre
- pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security, including alpha and beta versions
- pkgver = 1.1.0e
+ pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
+ pkgver = 1.1.1.d
pkgrel = 1
url = https://www.openssl.org
- arch = i686
arch = x86_64
license = custom:BSD
- depends = zlib
depends = perl
- depends = openssl102
optdepends = ca-certificates
- options = !makeflags
backup = etc/ssl/openssl.cnf
- source = https://www.openssl.org/source/openssl-1.1.0e.tar.gz
- source = https://www.openssl.org/source/openssl-1.1.0e.tar.gz.asc
- source = no-rpath.patch
+ source = https://www.openssl.org/source/openssl-1.1.1d.tar.gz
+ source = https://www.openssl.org/source/openssl-1.1.1d.tar.gz.asc
source = ca-dir.patch
- md5sums = 51c42d152122e474754aea96f66928c6
- md5sums = SKIP
- md5sums = dc78d3d06baffc16217519242ce92478
- md5sums = 381ecca640ea989c8deb57e8a2505c8c
+ validpgpkeys = 8657ABB260F056B1E5190839D9C4D26D0E604491
+ validpgpkeys = 7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C
+ sha256sums = 1e3a91bc1f9dfce01af26026f856e064eab4c8ee0a8f457b5ae30b40b8b711f2
+ sha256sums = SKIP
+ sha256sums = 0938c8d68110768db4f350a7ec641070686904f2fe7ba630ac94399d7dc8cc5e
pkgname = openssl-pre
diff --git a/PKGBUILD b/PKGBUILD
index a818b9ccac02..0ab36704ad42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,39 @@
-# Maintainer: lily wilson <lily@lily.ml>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
_pkgname=openssl
pkgname=$_pkgname-pre
-_ver=1.1.0e
+_ver=1.1.1d
# use a pacman compatible version scheme
-pkgver=${_ver/-/.}
-#pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
-#pkgver=$_ver
+pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
-pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security, including alpha and beta versions'
-arch=('i686' 'x86_64')
+pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
+arch=('x86_64')
url='https://www.openssl.org'
license=('custom:BSD')
-depends=('zlib' 'perl' 'openssl102')
+depends=('perl')
optdepends=('ca-certificates')
-options=('!makeflags')
backup=('etc/ssl/openssl.cnf')
-source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
- "https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz.asc"
- 'no-rpath.patch'
+source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
-md5sums=('51c42d152122e474754aea96f66928c6'
- 'SKIP'
- 'dc78d3d06baffc16217519242ce92478'
- '381ecca640ea989c8deb57e8a2505c8c')
-validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491' '7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
+sha256sums=('1e3a91bc1f9dfce01af26026f856e064eab4c8ee0a8f457b5ae30b40b8b711f2'
+ 'SKIP'
+ '0938c8d68110768db4f350a7ec641070686904f2fe7ba630ac94399d7dc8cc5e')
+validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
+ '7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
prepare() {
- cd $srcdir/$_pkgname-$_ver
+ cd "$srcdir/$_pkgname-$_ver"
- # remove rpath: http://bugs.archlinux.org/task/14367
- #patch -p0 -i $srcdir/no-rpath.patch
# set ca dir to /etc/ssl by default
- patch -p0 -i $srcdir/ca-dir.patch
+ patch -p0 -i "$srcdir/ca-dir.patch"
}
build() {
- cd $srcdir/$_pkgname-$_ver
-
- if [ "${CARCH}" == 'x86_64' ]; then
- openssltarget='linux-x86_64'
- optflags='enable-ec_nistp_64_gcc_128'
- elif [ "${CARCH}" == 'i686' ]; then
- openssltarget='linux-elf'
- optflags=''
- fi
+ cd "$srcdir/$_pkgname-$_ver"
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
- shared zlib ${optflags} \
- "${openssltarget}" \
+ shared no-ssl3-method enable-ec_nistp_64_gcc_128 linux-x86_64 \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
make depend
@@ -57,20 +41,16 @@ build() {
}
check() {
- cd $srcdir/$_pkgname-$_ver
-
- # make test now fails because CA.sh is gone and the patch
- # changes CA.pl.in, but not CA.pl. Will try to fix later.
-
+ cd "$srcdir/$_pkgname-$_ver"
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
- #patch -p0 -R -i $srcdir/ca-dir.patch
- #make test
- #patch -p0 -i $srcdir/ca-dir.patch
+ patch -p0 -R -i "$srcdir/ca-dir.patch"
+ make test
+ patch -p0 -i "$srcdir/ca-dir.patch"
}
package() {
- cd $srcdir/$_pkgname-$_ver
- make DESTDIR=$pkgdir MANDIR=$pkgdir/usr/share/man MANSUFFIX=ssl install
+ cd "$srcdir/$_pkgname-$_ver"
+ make DESTDIR=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/ca-dir.patch b/ca-dir.patch
index 1ad68f259dac..a1402435d711 100644
--- a/ca-dir.patch
+++ b/ca-dir.patch
@@ -1,6 +1,6 @@
---- apps/CA.pl.in 2006-04-28 02:30:49.000000000 +0200
-+++ apps/CA.pl.in 2010-04-01 00:35:02.600553509 +0200
-@@ -28,7 +28,7 @@
+--- apps/CA.pl.in 2018-09-11 14:48:19.000000000 +0200
++++ apps/CA.pl.in 2018-09-11 16:16:32.125629435 +0200
+@@ -33,7 +33,7 @@
my $PKCS12 = "$openssl pkcs12";
# default openssl.cnf file has setup as per the following
@@ -9,9 +9,9 @@
my $CAKEY = "cakey.pem";
my $CAREQ = "careq.pem";
my $CACERT = "cacert.pem";
---- apps/openssl.cnf 2009-04-04 20:09:43.000000000 +0200
-+++ apps/openssl.cnf 2010-04-01 00:35:02.607220681 +0200
-@@ -39,7 +39,7 @@
+--- apps/openssl.cnf 2018-09-11 14:48:20.000000000 +0200
++++ apps/openssl.cnf 2018-09-11 16:16:32.125629435 +0200
+@@ -43,7 +43,7 @@
####################################################################
[ CA_default ]
@@ -20,3 +20,12 @@
certs = $dir/certs # Where the issued certs are kept
crl_dir = $dir/crl # Where the issued crl are kept
database = $dir/index.txt # database index file.
+@@ -327,7 +327,7 @@
+ [ tsa_config1 ]
+
+ # These are used by the TSA reply generation only.
+-dir = ./demoCA # TSA root directory
++dir = /etc/ssl # TSA root directory
+ serial = $dir/tsaserial # The current serial number (mandatory)
+ crypto_device = builtin # OpenSSL engine to use for signing
+ signer_cert = $dir/tsacert.pem # The TSA signing certificate
diff --git a/no-rpath.patch b/no-rpath.patch
deleted file mode 100644
index ebd95e23d397..000000000000
--- a/no-rpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.shared.no-rpath 2005-06-23 22:47:54.000000000 +0200
-+++ Makefile.shared 2005-11-16 22:35:37.000000000 +0100
-@@ -153,7 +153,7 @@
- NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
-
--DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
-+DO_GNU_APP=LDFLAGS="$(CFLAGS)"
-
- #This is rather special. It's a special target with which one can link
- #applications without bothering with any features that have anything to