summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Berla2022-12-10 19:54:28 -1000
committerCorey Berla2022-12-10 19:54:28 -1000
commit23c5117b07897044f3d72932fd11e2aecb04def5 (patch)
treef4959a934bc4f3d5e38a4cbad1a93d7859fea20c
parent959cf65dbd2dbad1f2a1d3f686ecf52a78335aa5 (diff)
downloadaur-23c5117b07897044f3d72932fd11e2aecb04def5.tar.gz
Update 2022.12.05
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8c058f37ad4..2abdab63592b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
+# Maintainer: Corey Berla <corey@berla.me>
+# Contributor: M.Reynolds <blackboxnetworkproject@gmail.com>
# Contributor: Vlad M. <vlad@archlinux.net>
# Contributor: Christophe Gueret <christophe.gueret@gmail.com>
# Contributor: josephgbr <rafael.f.f1@gmail.com>
@@ -8,27 +9,27 @@
# Contributor: Gordin <9ordin @t gmail.com>
pkgname=nautilus-dropbox
-pkgver=2020.03.04
-pkgrel=4
-pkgdesc="Dropbox for Linux - Nautilus extension"
-arch=('i686' 'x86_64')
+pkgdesc="Dropbox Nautilus Extension"
+pkgver=2022.12.05
+pkgrel=1
+arch=(x86_64)
url="https://www.dropbox.com/"
license=('custom:CC-BY-ND-3' 'GPL')
-depends=('nautilus' 'dropbox' 'libnotify' 'hicolor-icon-theme')
-makedepends=('python' 'python-docutils' 'python-gobject' 'gdk-pixbuf2')
+depends=(nautilus libnautilus-extension dropbox)
+makedepends=(python python-docutils python-gobject gnome-common)
options=('!libtool' '!emptydirs')
-source=("https://linux.dropbox.com/packages/$pkgname-$pkgver.tar.bz2")
-sha256sums=('f3704103e8c646ec48cd9daf9af2183c6b492c59edf93d8768c14861cb404cca')
+_commit=8cc1635a0e0e6edf90beb4b6f9c9ecb2b39e41f3
+source=("git+https://github.com/dropbox/nautilus-dropbox.git#commit=$_commit")
+sha256sums=('SKIP')
build() {
- cd "$pkgname-$pkgver"
- # sed -i "s/python/python2/" configure dropbox.in Makefile.in rst2man.py
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd nautilus-dropbox
+ ./autogen.sh
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd nautilus-dropbox
make DESTDIR="$pkgdir" install
# install the common license
@@ -39,3 +40,4 @@ package() {
rm "$pkgdir/usr/share/applications/dropbox.desktop"
rm "$pkgdir/usr/share/man/man1/dropbox.1"
}
+