summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 23:15:37 +0200
committerGustavo Alvarez2016-10-19 23:15:37 +0200
commit23c6f97c29ddc3094bd72ece06f5f664756da3d5 (patch)
tree699e125fe2efe23a4a73b1b8543c6d9272d0ab9b
parent7aef7c146762cf9f659bb77213e06ab631d16967 (diff)
downloadaur-23c6f97c29ddc3094bd72ece06f5f664756da3d5.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a7760303063..b1807c61c29e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 17 06:10:51 UTC 2016
+# Wed Oct 19 21:15:34 UTC 2016
pkgbase = vapoursynth-plugin-mcdegrainsharp-git
pkgdesc = Plugin for Vapoursynth: mcdegrainsharp (GIT version)
pkgver = r4
@@ -8,12 +8,13 @@ pkgbase = vapoursynth-plugin-mcdegrainsharp-git
arch = any
license = GPL
makedepends = git
+ depends = vapoursynth
depends = vapoursynth-plugin-genericfilters-git
depends = vapoursynth-plugin-mvtools
provides = vapoursynth-plugin-mcdegrainsharp
conflicts = vapoursynth-plugin-mcdegrainsharp
source = mcdegrainsharp::git+https://gist.github.com/b5399b1801072458fc80.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-mcdegrainsharp-git
diff --git a/PKGBUILD b/PKGBUILD
index f61ee391ff02..2fe25b6df45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,17 @@ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url='https://gist.github.com/4re'
license=('GPL')
-depends=('vapoursynth-plugin-genericfilters-git'
+depends=('vapoursynth'
+ 'vapoursynth-plugin-genericfilters-git'
'vapoursynth-plugin-mvtools'
)
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://gist.github.com/b5399b1801072458fc80.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -25,5 +26,7 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}