summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDictator Mei2018-08-05 19:32:11 +0900
committerDictator Mei2018-08-05 19:32:11 +0900
commit23d4bfd8702b815561a192c4a1252e79095d253b (patch)
tree2478980c0bbc8f54d5c38d16efd794a08d9c3e7d
downloadaur-23d4bfd8702b815561a192c4a1252e79095d253b.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--30-touchpad.conf8
-rw-r--r--PKGBUILD13
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0106b2737af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = libinput-touchpad
+ pkgdesc = Libinput's touchpad configuration supplement
+ pkgver = 1.0
+ pkgrel = 1
+ arch = any
+ depends = xf86-input-libinput
+ source = 30-touchpad.conf
+ sha512sums = b8446632a2515aa61d66a993dcc33db27dde3346d67d8b2cce8b588957639e6caac07534b1fbf5e3d169fa17e2cb0afa0c1337c251e70b4ff237e9ccdbf09424
+
+pkgname = libinput-touchpad
+
diff --git a/30-touchpad.conf b/30-touchpad.conf
new file mode 100644
index 000000000000..e69542e9ebb4
--- /dev/null
+++ b/30-touchpad.conf
@@ -0,0 +1,8 @@
+Section "InputClass"
+ Identifier "libinput touchpad catchall"
+ MatchIsTouchpad "on"
+ MatchDevicePath "/dev/input/event*"
+ Driver "libinput"
+ Option "Tapping" "on"
+ Option "NaturalScrolling" "true"
+EndSection
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8abda867d92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,13 @@
+# Maintainer: Dictator Mei <dctxmei@gmail.com>
+pkgname=libinput-touchpad
+pkgver=1.0
+pkgrel=1
+pkgdesc="Libinput's touchpad configuration supplement"
+arch=('any')
+depends=('xf86-input-libinput')
+source=("30-touchpad.conf")
+sha512sums=('b8446632a2515aa61d66a993dcc33db27dde3346d67d8b2cce8b588957639e6caac07534b1fbf5e3d169fa17e2cb0afa0c1337c251e70b4ff237e9ccdbf09424')
+
+package() {
+ install -Dm644 "$srcdir"/30-touchpad.conf "$pkgdir"/usr/share/X11/xorg.conf.d/30-touchpad.conf
+}