summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimur Kiyivinski2016-09-29 10:50:14 +0800
committerTimur Kiyivinski2016-09-29 10:50:14 +0800
commit23e33017deb584e7e649c1f19d056f087b722fe4 (patch)
tree80c73f1ca5c7452bbd8fcf0db9c17610487b9448
parent056da72ff42589895645ea2b18fad9df88137776 (diff)
downloadaur-23e33017deb584e7e649c1f19d056f087b722fe4.tar.gz
[REFACTOR] Update kitematic [ADD] Desktop file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--kitematic.desktop8
-rw-r--r--kitematic.install8
-rw-r--r--kitematic.svg1
5 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89178c2b745e..56aa24f280a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kitematic-git
pkgdesc = Visual Docker Container Management
- pkgver = 2129.ece9cfa
+ pkgver = 2167.95ce61a
pkgrel = 1
url = https://github.com/docker/kitematic
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cbb22740e8f6..75bcbc043395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timur Kiyivinski <timur@linux.com>
pkgname=kitematic-git
-pkgver=2129.ece9cfa
+pkgver=2167.95ce61a
pkgrel=1
pkgdesc='Visual Docker Container Management'
arch=('x86_64')
@@ -10,8 +10,12 @@ license=('Apache')
depends=('docker' 'nodejs')
makedepends=('git' 'npm' 'nodejs-grunt-cli')
conflicts=('kitematic')
-source=("$pkgname::git+https://github.com/docker/kitematic.git")
-sha256sums=('SKIP')
+source=("$pkgname::git+https://github.com/docker/kitematic.git" "${pkgname/\-git/}.desktop" "${pkgname/\-git/}.svg")
+sha256sums=(
+ 'SKIP'
+ '5b1a905c36a22f454a483563bae8036822c35814e8de0d7816a56f3f6355be58'
+ '32aafe8f1235a043094e031e9b1b978e26feeb0ebe8232d6269fcb53f1665706'
+)
pkgver() {
cd "$pkgname"
@@ -26,6 +30,8 @@ build() {
package() {
install -dm755 "$pkgdir"/{opt,usr/bin}
+ install -Dm644 "${pkgname/\-git/}.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname/\-git/}.svg"
+ install -Dm644 "${pkgname/\-git/}.desktop" "$pkgdir/usr/share/applications/${pkgname/\-git/}.desktop"
cp -R "$pkgname/dist/Kitematic-linux-x64/" "$pkgdir/opt/$pkgname"
ln -s "/opt/$pkgname/Kitematic" "$pkgdir/usr/bin/kitematic"
}
diff --git a/kitematic.desktop b/kitematic.desktop
new file mode 100644
index 000000000000..7cd738f74228
--- /dev/null
+++ b/kitematic.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Kitematic
+Comment=Visual Docker Container Management
+Exec=/usr/bin/kitematic
+Terminal=false
+Icon=kitematic
+Categories=System
diff --git a/kitematic.install b/kitematic.install
new file mode 100644
index 000000000000..c0b0d4365a43
--- /dev/null
+++ b/kitematic.install
@@ -0,0 +1,8 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/kitematic.svg b/kitematic.svg
new file mode 100644
index 000000000000..b9381c6de734
--- /dev/null
+++ b/kitematic.svg
@@ -0,0 +1 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?><svg width="256px" height="256px" viewBox="0 0 256 256" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" preserveAspectRatio="xMinYMin meet"><g><path d="M203.031173,255.890648 L128.095417,255.890648 C103.121498,255.890648 78.13358,256.13669 53.1606614,255.890648 C27.8077441,255.640604 5.5058168,237.389435 1.01583144,212.256071 C-0.594163313,203.243506 0.191834124,193.502815 0.191834124,184.394233 L0.191834124,82.0794674 C0.191834124,72.5438117 0.123834345,63.0051554 0.191834124,53.4694996 C0.350833605,31.2306381 13.9267893,10.9201114 35.0107206,3.22977608 C45.4596865,-0.581885766 56.341651,0.0372217351 67.2366155,0.0372217351 L114.513461,0.0372217351 C143.458367,0.0372217351 172.402273,-0.000784864328 201.347178,0.0372217351 C220.939114,0.0632262505 239.147055,9.46885943 249.029023,26.7318569 C255.633001,38.2698604 256,50.4139691 256,63.1711842 L256,162.133368 L256,199.274817 C256,216.548816 250.320019,232.626608 236.623063,243.875561 C227.200094,251.614905 215.223133,255.890648 203.031173,255.890648" fill="#3CB5E8"></path><path d="M46.365,63.143 L46.365,195.651 L82.694,195.651 L82.527,152.94 L99.352,132.536 L119.923,195.651 L158.868,195.651 L126.955,107.256 L158.951,62.975 L113.247,62.975 L82.527,99.22 L82.527,63.059 L46.365,63.143" fill="#FFFFFF"></path><path d="M215.119,63.059 L165.842,63.059 L194.27,106.196 L166.903,195.651 L215.119,195.651 L215.119,63.059" fill="#FFFFFF"></path></g></svg> \ No newline at end of file