summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUncle Hunto2018-10-15 19:42:51 -0700
committerUncle Hunto2018-10-15 19:42:51 -0700
commit23f16489a24de4a4df8511d08db7ed3e283924c3 (patch)
tree176d850ad0b90de7537d420481e9052d9e359ec2
parent347259aca4201475ec290f688f6cd38936deab18 (diff)
downloadaur-23f16489a24de4a4df8511d08db7ed3e283924c3.tar.gz
Add SSLv3 patch
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--bitcoin-SSLfix.patch10
3 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 148ea026d6ce..17b4613a4b89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Oct 16 00:28:53 UTC 2018
+# Tue Oct 16 02:42:12 UTC 2018
pkgbase = bitcoin-gui-git
pkgdesc = Most recent stable branch, UPNP disabled, w/ Bitcoin binaries, dev tools, GUI, and wallet
pkgver = v0.17.0.r1.g5b47b8efd4
- pkgrel = 1
+ pkgrel = 2
url = https://bitcoin.org/en/download
install = bitcoin-qt.install
arch = i686
@@ -37,12 +37,15 @@ pkgbase = bitcoin-gui-git
source = git+https://github.com/bitcoin/bitcoin.git#branch=0.17
source = git+https://github.com/bitcoin-core/packaging.git
source = bitcoin-qt.install
+ source = bitcoin-SSLfix.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c
+ sha256sums = d9335c9b5c417b035f7be6cb3af7670487ec56bd71adaaad052e4913a5ef8495
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 67383fa1dd2f9576cc3c282f3a9b8c5f2d3eaa13799a6a7eb9eb2969face0ddaf6bb82c286c928b89397d8d2c9ba2efe9a603442f4bf6ed6d89ae9323c169375
+ sha512sums = 6c5b2a7e73eba407fd04e8571c719f0ca46bd9be53af329d6a139058ff5cd8e82727d395891c12dccfbdaf2f107f167a8033df9f50e13917da83446f0cb74a8f
pkgname = bitcoin-gui-git
diff --git a/PKGBUILD b/PKGBUILD
index 77e4aaaba9fd..b4514c09ded5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _branch=0.17
#_tag=$(git ls-remote -t --refs https://github.com/bitcoin/bitcoin.git | awk '{print $2}' | LC_ALL=C sort -bfV | sed '/rc[0-9]/d' | tail -n1 | sed -n -e 's/^.*tags\///p')
pkgname=bitcoin-gui-git
pkgver=v0.17.0.r1.g5b47b8efd4
-pkgrel=1
+pkgrel=2
pkgdesc='Most recent stable branch, UPNP disabled, w/ Bitcoin binaries, dev tools, GUI, and wallet'
arch=('i686' 'x86_64')
url="https://bitcoin.org/en/download"
@@ -18,19 +18,28 @@ conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
install=bitcoin-qt.install
source=("git+https://github.com/bitcoin/bitcoin.git#branch=${_branch}"
"git+https://github.com/bitcoin-core/packaging.git"
- 'bitcoin-qt.install')
+ 'bitcoin-qt.install'
+ 'bitcoin-SSLfix.patch')
sha256sums=('SKIP'
'SKIP'
- 'ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c')
+ 'ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c'
+ 'd9335c9b5c417b035f7be6cb3af7670487ec56bd71adaaad052e4913a5ef8495')
sha512sums=('SKIP'
'SKIP'
- '67383fa1dd2f9576cc3c282f3a9b8c5f2d3eaa13799a6a7eb9eb2969face0ddaf6bb82c286c928b89397d8d2c9ba2efe9a603442f4bf6ed6d89ae9323c169375')
+ '67383fa1dd2f9576cc3c282f3a9b8c5f2d3eaa13799a6a7eb9eb2969face0ddaf6bb82c286c928b89397d8d2c9ba2efe9a603442f4bf6ed6d89ae9323c169375'
+ '6c5b2a7e73eba407fd04e8571c719f0ca46bd9be53af329d6a139058ff5cd8e82727d395891c12dccfbdaf2f107f167a8033df9f50e13917da83446f0cb74a8f')
pkgver() {
cd "$srcdir/bitcoin"
-git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/bitcoin"
+ patch -p1 < "$srcdir/bitcoin-SSLfix.patch"
+}
+
+
build() {
cd "$srcdir/bitcoin"
msg2 'Building...'
diff --git a/bitcoin-SSLfix.patch b/bitcoin-SSLfix.patch
new file mode 100644
index 000000000000..0e6a16bcc3cc
--- /dev/null
+++ b/bitcoin-SSLfix.patch
@@ -0,0 +1,10 @@
+--- a/src/qt/bitcoin.cpp 2018-10-15 18:45:35.610803000 -0700
++++ b/src/qt/bitcoin.cpp 2018-10-15 19:19:02.004967860 -0700
+@@ -579,6 +579,7 @@
+ #if QT_VERSION >= 0x050500
+ // Because of the POODLE attack it is recommended to disable SSLv3 (https://disablessl3.com/),
+ // so set SSL protocols to TLS1.0+.
++ QSslSocket::sslLibraryVersionString();
+ QSslConfiguration sslconf = QSslConfiguration::defaultConfiguration();
+ sslconf.setProtocol(QSsl::TlsV1_0OrLater);
+ QSslConfiguration::setDefaultConfiguration(sslconf);