summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2022-12-11 17:57:08 -0500
committerShayne Hartford2022-12-11 17:57:08 -0500
commit2402c1e9fcc125ba89f92f4c90973eb7cb6ee2d2 (patch)
tree98849d1af0807741477226780e0cbc254b978697
downloadaur-2402c1e9fcc125ba89f92f4c90973eb7cb6ee2d2.tar.gz
2.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ddee31a5347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = launcher-curseforge-bin
+ pkgdesc = Integrates the Curseforge Modpack installation button to any MultiMC based launcher
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ShayBox/launcher-curseforge
+ arch = x86_64
+ license = MIT
+ optdepends = multimc
+ optdepends = polymc
+ optdepends = prismlauncher
+ source = https://github.com/ShayBox/launcher-curseforge/releases/download/2.0.0/Linux-x86_64.zip
+ sha512sums = 1d49be96232cb3afeaa5643e90f5e3f773a10c63c5597269489c9c7bb452a8bc013d5253fdb3939a2a773ea76ff05de29dd90bef24a0c64667c335f9a8449888
+
+pkgname = launcher-curseforge-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f495dbf29e0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Shayne Hartford <shayneehartford@gmail.com>
+
+_pkgname=launcher-curseforge
+pkgname="${_pkgname}-bin"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Integrates the Curseforge Modpack installation button to any MultiMC based launcher "
+arch=("x86_64")
+url="https://github.com/ShayBox/${_pkgname}"
+license=("MIT")
+source=("${url}/releases/download/${pkgver}/Linux-x86_64.zip")
+sha512sums=("1d49be96232cb3afeaa5643e90f5e3f773a10c63c5597269489c9c7bb452a8bc013d5253fdb3939a2a773ea76ff05de29dd90bef24a0c64667c335f9a8449888")
+optdepends=("multimc" "polymc" "prismlauncher")
+
+prepare() {
+ ar x "${_pkgname}_${pkgver}_amd64.deb"
+ tar -zxvf data.tar.gz
+}
+
+package() {
+ install -Dm755 "usr/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+}