summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgandalf32019-05-17 16:34:12 -0700
committergandalf32019-05-17 16:37:47 -0700
commit240c492d30398d122f35fc3182c75eada7ef39e9 (patch)
tree401cd3e6e6d326b5367ec1e7ba3c8b5ec40981dd
downloadaur-240c492d30398d122f35fc3182c75eada7ef39e9.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD51
-rw-r--r--irssi-connection-set-key.patch.patch44
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6837b2b29791
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = irssi-passwd
+ pkgdesc = Modular text mode IRC client with Perl scripting, with irssi-passwd patch
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/swick/irssi-passwd
+ arch = x86_64
+ license = GPL
+ depends = glib2
+ depends = openssl
+ depends = libotr
+ optdepends = perl-libwww: for the scriptassist script
+ conflicts = irssi
+ backup = etc/irssi.conf
+ source = https://github.com/irssi/irssi/releases/download/1.2.0/irssi-1.2.0.tar.xz
+ source = https://github.com/irssi/irssi/releases/download/1.2.0/irssi-1.2.0.tar.xz.asc
+ source = https://raw.githubusercontent.com/swick/irssi-passwd/master/irssi-connection-set-key.patch
+ source = https://raw.githubusercontent.com/swick/irssi-passwd/master/passwd.pl
+ source = irssi-connection-set-key.patch.patch
+ validpgpkeys = 7EE65E3082A5FB06AC7C368D00CCB587DDBEF0E1
+ sha512sums = 343530ca63355dd6683e84f31602c9162e1e3158e52ce81e37519d1e42abbdcb621fb710fcb605fcafd7e7ea3f2c30ed62607d4ea91d8c8dc29bf893e54aee40
+ sha512sums = SKIP
+ sha512sums = 9610c2207777cd3699a9af077fa41da2131ddb97b57c5420abb155e421ca619cd03d5c242b50437acf9bfc1242945fb6d245cbfe164c5a159b83baa439544b31
+ sha512sums = 0b6985f9db8c641997109d1ef1ca8d6ae87dbc9f68033062ecca020b5efb86f1f3c3f7e2cf3f3971f826e52b001838acef01553b38338ebdf948ee7bf14575d1
+ sha512sums = 77c88bf55624b9c164a2fd0e119bbba9188deba1f187da2d1ae680a0568eb2c7594dbcb8f9d8626e50c6d65e55c35a11e80f074ff4e7739c6bc083fe534066d1
+
+pkgname = irssi-passwd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31c2cfc1f48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: gandalf3 <zzyxpaw at gmail>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Dan McGee <dan@archlinux.org>
+
+pkgname=irssi-passwd
+_pkgname=irssi
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Modular text mode IRC client with Perl scripting, with irssi-passwd patch'
+url='https://github.com/swick/irssi-passwd'
+arch=('x86_64')
+license=('GPL')
+depends=('glib2' 'openssl' 'libotr')
+optdepends=('perl-libwww: for the scriptassist script')
+conflicts=('irssi')
+backup=('etc/irssi.conf')
+source=(https://github.com/irssi/irssi/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.xz{,.asc}
+ https://raw.githubusercontent.com/swick/irssi-passwd/master/irssi-connection-set-key.patch
+ https://raw.githubusercontent.com/swick/irssi-passwd/master/passwd.pl
+ irssi-connection-set-key.patch.patch)
+sha512sums=('343530ca63355dd6683e84f31602c9162e1e3158e52ce81e37519d1e42abbdcb621fb710fcb605fcafd7e7ea3f2c30ed62607d4ea91d8c8dc29bf893e54aee40'
+ 'SKIP'
+ '9610c2207777cd3699a9af077fa41da2131ddb97b57c5420abb155e421ca619cd03d5c242b50437acf9bfc1242945fb6d245cbfe164c5a159b83baa439544b31'
+ '0b6985f9db8c641997109d1ef1ca8d6ae87dbc9f68033062ecca020b5efb86f1f3c3f7e2cf3f3971f826e52b001838acef01553b38338ebdf948ee7bf14575d1'
+ '77c88bf55624b9c164a2fd0e119bbba9188deba1f187da2d1ae680a0568eb2c7594dbcb8f9d8626e50c6d65e55c35a11e80f074ff4e7739c6bc083fe534066d1')
+validpgpkeys=('7EE65E3082A5FB06AC7C368D00CCB587DDBEF0E1') # The Irssi project <staff@irssi.org>
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ patch --follow-symlinks ${srcdir}/irssi-connection-set-key.patch < ${srcdir}/irssi-connection-set-key.patch.patch -o irssi-connection-set-key_patched.patch
+ patch -p1 < irssi-connection-set-key_patched.patch
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-proxy \
+ --with-perl-lib=vendor \
+ --with-otr
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "${pkgdir}/usr/share/irssi/scripts"
+ install -D -m755 ${srcdir}/passwd.pl ${pkgdir}/usr/share/irssi/scripts/
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/irssi-connection-set-key.patch.patch b/irssi-connection-set-key.patch.patch
new file mode 100644
index 000000000000..830016ffdb76
--- /dev/null
+++ b/irssi-connection-set-key.patch.patch
@@ -0,0 +1,44 @@
+38,40c38,40
+< + else if (strcmp(key, "ssl_cert") == 0) {
+< + g_free_not_null(server->connrec->ssl_cert);
+< + server->connrec->ssl_cert = g_strdup(value);
+---
+> + else if (strcmp(key, "tls_cert") == 0) {
+> + g_free_not_null(server->connrec->tls_cert);
+> + server->connrec->tls_cert = g_strdup(value);
+42,44c42,44
+< + else if (strcmp(key, "ssl_pkey") == 0) {
+< + g_free_not_null(server->connrec->ssl_pkey);
+< + server->connrec->ssl_pkey = g_strdup(value);
+---
+> + else if (strcmp(key, "tls_pkey") == 0) {
+> + g_free_not_null(server->connrec->tls_pkey);
+> + server->connrec->tls_pkey = g_strdup(value);
+46,48c46,48
+< + else if (strcmp(key, "ssl_cafile") == 0) {
+< + g_free_not_null(server->connrec->ssl_cafile);
+< + server->connrec->ssl_cafile = g_strdup(value);
+---
+> + else if (strcmp(key, "tls_cafile") == 0) {
+> + g_free_not_null(server->connrec->tls_cafile);
+> + server->connrec->tls_cafile = g_strdup(value);
+50,52c50,52
+< + else if (strcmp(key, "ssl_capath") == 0) {
+< + g_free_not_null(server->connrec->ssl_capath);
+< + server->connrec->ssl_capath = g_strdup(value);
+---
+> + else if (strcmp(key, "tls_capath") == 0) {
+> + g_free_not_null(server->connrec->tls_capath);
+> + server->connrec->tls_capath = g_strdup(value);
+54,55c54,55
+< + else if (strcmp(key, "use_ssl") == 0) {
+< + server->connrec->use_ssl = (strcmp(value, "no") != 0);
+---
+> + else if (strcmp(key, "use_tls") == 0) {
+> + server->connrec->use_tls = (strcmp(value, "no") != 0);
+57,58c57,58
+< + else if (strcmp(key, "ssl_verify") == 0) {
+< + server->connrec->ssl_verify = (strcmp(value, "no") != 0);
+---
+> + else if (strcmp(key, "tls_verify") == 0) {
+> + server->connrec->tls_verify = (strcmp(value, "no") != 0);