summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2016-11-02 13:10:49 -0400
committerKyle Keen2016-11-02 13:10:49 -0400
commit2416d8352976089b2157aff564dc305ea8607ec1 (patch)
tree0d4addc8431d9a3f096ee2e2f81b01a759f6ab10
parent0924486e50824296388e547bafa302089b835b1b (diff)
downloadaur-2416d8352976089b2157aff564dc305ea8607ec1.tar.gz
half fixed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--edelib.3592.patch45
3 files changed, 61 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7b8219df5ae..fd826bf4e759 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Nov 2 17:10:47 UTC 2016
pkgbase = edelib
pkgdesc = Component construction library for Equinox Desktop Environment
pkgver = 2.1
@@ -8,11 +10,13 @@ pkgbase = edelib
license = LGPL
makedepends = ftjam
depends = fltk
- depends = dbus-core
+ depends = dbus
depends = libstdc++5
depends = python
source = http://downloads.sourceforge.net/project/ede/edelib/2.1/edelib-2.1.tar.gz
+ source = edelib.3592.patch
md5sums = 2e6ee2e1ceaea327967ed55868a1cb9f
+ md5sums = 530ddd4bbf774eb99a4fff3e7e705891
pkgname = edelib
diff --git a/PKGBUILD b/PKGBUILD
index c57a0fdae4be..9e44d933c2ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,24 @@ arch=('i686' 'x86_64')
url="http://equinox-project.org/"
_watch="http://equinox-project.org/wiki/Download"
license=('LGPL')
-depends=('fltk' 'dbus-core' 'libstdc++5' 'python')
+depends=('fltk' 'dbus' 'libstdc++5' 'python')
makedepends=('ftjam')
-source=(http://downloads.sourceforge.net/project/ede/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
-md5sums=('2e6ee2e1ceaea327967ed55868a1cb9f')
+source=("http://downloads.sourceforge.net/project/ede/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+ 'edelib.3592.patch')
+md5sums=('2e6ee2e1ceaea327967ed55868a1cb9f'
+ '530ddd4bbf774eb99a4fff3e7e705891')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/edelib.3592.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
./autogen.sh
CFLAGS="-mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fPIC"
CXXFLAGS="-mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fPIC"
- MAKEFLAGS="-j2"
+ MAKEFLAGS="-j1"
./configure --prefix=/usr
jam
}
diff --git a/edelib.3592.patch b/edelib.3592.patch
new file mode 100644
index 000000000000..f77c2e883045
--- /dev/null
+++ b/edelib.3592.patch
@@ -0,0 +1,45 @@
+-- a/src/WindowUtils.cpp
++++ b/src/WindowUtils.cpp
+@@ -1,5 +1,5 @@
+ /*
+- * $Id: WindowUtils.cpp 3106 2011-10-21 20:26:08Z karijes $
++ * $Id: WindowUtils.cpp 3592 2014-12-02 12:48:07Z karijes $
+ *
+ * Window utils
+ * Copyright (c) 1998-2006 by Bill Spitzak and others
+@@ -33,8 +33,10 @@
+ * These are defined in FLTK as hidden variables for some internal hacks, but are used here.
+ * XXX: possible changes in future FLTK versions
+ */
++#if 0
+ extern char fl_show_iconic;
+ extern int fl_disable_transient_for;
++#endif
+
+ EDELIB_NS_BEGIN
+
+@@ -165,7 +167,7 @@
+ XChangeProperty(fl_display, xp->xid, XA_WM_CLASS, XA_STRING, 8, 0, (unsigned char *)buffer, p-buffer-1);
+ }
+
+- if(win->non_modal() && xp->next && !fl_disable_transient_for) {
++ if(win->non_modal() && xp->next /* && !fl_disable_transient_for */) {
+ // find some other window to be "transient for":
+ Fl_Window* wp = xp->next->w;
+ while(wp->parent())
+@@ -193,13 +195,14 @@
+ XWMHints *hints = XAllocWMHints();
+ hints->input = True;
+ hints->flags = InputHint;
+-
++#if 0
+ if(fl_show_iconic) {
+ hints->flags |= StateHint;
+ hints->initial_state = IconicState;
+ fl_show_iconic = 0;
+ showit = 0;
+ }
++#endif
+
+ // This is not removed so it can be used with windows inherited from Fl_Window
+ if(win->icon()) {