summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Krizek2023-07-25 15:18:42 +0200
committerTom Krizek2023-07-25 15:19:30 +0200
commit241b899d784661ae7be2514fb6cf4e4b492d919c (patch)
treea763763ae5d3edcfab14f6dc1786f3089a6c5cf8
parentb58c67b57811d49c509119643f1237b362c27c37 (diff)
downloadaur-241b899d784661ae7be2514fb6cf4e4b492d919c.tar.gz
update to 2.4.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3228ad278016..f4265f612feb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
pkgbase = python-dnspython-git
pkgdesc = A DNS toolkit for Python
- pkgver = v2.1.0.r200.ab53090
+ pkgver = 2.4.0
pkgrel = 1
url = http://www.dnspython.org
arch = any
- license = ISC
+ license = custom:ISC
checkdepends = python-idna
checkdepends = python-cryptography
checkdepends = python-trio
+ checkdepends = python-pytest
makedepends = python-setuptools
- makedepends = python-pytest
- makedepends = python-httpx
- makedepends = python-h2
depends = python
- optdepends = python-idna: support for update IDNA 2008
optdepends = python-cryptography: DNSSEC support
- optdepends = python-httpx: DNS-over-HTTPS support
- optdepends = python-h2: DNS-over-HTTPS support
- optdepends = python-trio: async I/O backend
- optdepends = python-curio: async I/O backend
- optdepends = python-sniffio: async I/O
+ optdepends = python-requests-toolbelt: DoH support
+ optdepends = python-idna: support for updated IDNA 2008
+ optdepends = python-curio: async support
+ optdepends = python-trio: async support
+ optdepends = python-sniffio: async support
provides = python-dnspython
conflicts = python-dnspython
source = dnspython::git+https://github.com/rthalley/dnspython.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = python-dnspython-git
diff --git a/PKGBUILD b/PKGBUILD
index adf87082afa7..fcb1e8555d24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
-# Maintainer: Tomas Krizek <tomas.krizek@nic.cz>
+# Maintainer: Tom Krizek <tkrizek@isc.org>
pkgname=python-dnspython-git
_pkgname=dnspython
-pkgver=v2.1.0.r200.ab53090
+pkgver=2.4.0
pkgrel=1
pkgdesc="A DNS toolkit for Python"
arch=('any')
url="http://www.dnspython.org"
-license=('ISC')
+license=('custom:ISC')
+depends=('python')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
makedepends=(
'python-setuptools'
- 'python-pytest'
- 'python-httpx'
- 'python-h2'
# 'cython' # uncomment dep & build option for cython optimization speedup
)
-checkdepends=('python-idna' 'python-cryptography' 'python-trio')
-depends=('python')
-optdepends=(
- 'python-idna: support for update IDNA 2008'
- 'python-cryptography: DNSSEC support'
- 'python-httpx: DNS-over-HTTPS support'
- 'python-h2: DNS-over-HTTPS support'
- 'python-trio: async I/O backend'
- 'python-curio: async I/O backend'
- 'python-sniffio: async I/O'
-)
+checkdepends=('python-idna' 'python-cryptography' 'python-trio' 'python-pytest')
+optdepends=('python-cryptography: DNSSEC support'
+ 'python-requests-toolbelt: DoH support'
+ 'python-idna: support for updated IDNA 2008'
+ 'python-curio: async support'
+ 'python-trio: async support'
+ 'python-sniffio: async support')
source=("${_pkgname}::git+https://github.com/rthalley/${_pkgname}.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -45,7 +39,8 @@ build() {
check() {
cd "${srcdir}/${_pkgname}"
- python setup.py test
+ # https://github.com/rthalley/dnspython/issues/622
+ pytest -k 'not test_unpickle'
}
package() {