summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Mischka2016-10-23 21:25:00 -0500
committerJacob Mischka2016-10-23 21:28:13 -0500
commit242000a8ad1f1acf1916c5d7d2ef316a15c0a3d7 (patch)
treee9c5b7b73ed81696fe3802ec07b02024d4999b3f
downloadaur-242000a8ad1f1acf1916c5d7d2ef316a15c0a3d7.tar.gz
Initial commit 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea65dfc22198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon Oct 24 02:27:42 UTC 2016
+pkgbase = firebase-admin
+ pkgdesc = Firebase Management Cross Platform Application.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://firebaseadmin.com/
+ arch = any
+ license = GPL3
+ source = https://firebaseadmin.com/download.php?file=1.0.0/firebase-admin-linux-1.0.0.zip
+ md5sums = 9e28e19fe8cdbf5d3f513067eea0f9f4
+
+pkgname = firebase-admin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1697d8293d2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jacob Mischka <jacob@mischka.me>
+
+pkgname=firebase-admin
+_foldername='Firebase Admin'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Firebase Management Cross Platform Application.'
+url='https://firebaseadmin.com/'
+license=('GPL3')
+source=('https://firebaseadmin.com/download.php?file=1.0.0/firebase-admin-linux-1.0.0.zip')
+arch=('any')
+md5sums=('9e28e19fe8cdbf5d3f513067eea0f9f4')
+
+package(){
+ mv "$_foldername/$_foldername" "$_foldername/$pkgname"
+ install -dm755 "$pkgdir/opt/"
+ cp -a --reflink=auto "$_foldername" "$pkgdir/opt/$pkgname/"
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}